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Lesson 1 
Starting SPSS 

 
After This Lesson, You Will Know 

• How to start SPSS 
• What the opening SPSS screen looks like 

 
Key Words 

• Data View 
• Variable View 
• Data Editor 
• Viewer 
 
With this lesson you will start your journey on learning how to use SPSS, the most 

powerful and easiest-to-use data analysis package available. 
Keep in mind that throughout these lessons we expect you to work along with us. 

It’s only through hands-on experiences that you will master the basic and advanced 
features of this program. 
Starting SPSS 

SPSS is started by clicking the icon (or the name representing the program) 
that represents the application either on the Start Menu in Windows or on the 
desktop on the Macintosh.  
 
Tip: To place SPSS on the Windows Start menu in Windows, open the Explorer, locate the 
SPSS executive file (spss.exe), and drag and drop it on to the Start menu. To place it on the 
Mac desktop, just locate it (perhaps using Sherlock) and drag it to the desktop. 
 
The SPSS Opening Window 

As you can see in Figure 1, the opening window presents a series of options that 
allow you to select from running the SPSS tutorial, entering data, posing an established 
query, creating a new query using the Database Wizard, or opening an existing source 
of data (an existing file). Should you not want to see this screen each time you open 
SPSS, then click on the Don’t show this dialog in the future box in the lower left corner 
of the window.  
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Figure 1 The Opening SPSS Window 
 

The SPSS for Windows dialog box 
For our purposes, we will click the Type in data option since it is likely to be the one 

you fist select upon opening and learning SPSS. Once you do this, the Data View 
window (also called the Data Editor) you see in Figure 2 becomes active. This is where 
you enter data you want to use with SPSS once that data has been defined. Although 
you cannot see it when SPSS first opens, there is another open (but not active) window 
as well. This is the Variable View where variables are defined and the parameters for 
those variables are set. We will cover the Data and Variable Views in Lesson 5.  

 

 
 

Figure 2 The Data View window 
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The Viewer displays statistical results and charts that you create. An example of 
the Viewer window is shown in Figure 3. A data set is created using the Data Editor 
and once the set is analyzed or graphed, you examine the results of the analysis in the 
Viewer. 

 

 
 

Figure 3 The Viewer 
 

If you think the Data Editor is similar to a spreadsheet in form and function, you are 
right. In form, it certainly is, since the Data Editor consists of rows and columns just like 
in Excel and Lotus 2-3. Values can be entered and then manipulated. In function as well, 
the Data Editor is much like a spreadsheet. Values that are entered can be transformed, 
sorted, rearranged, and more. In addition, SPSS can use formulas to compute new 
variables and values from existing ones, as you will learn in Lesson 12. 

As you will learn in Lesson 10, one of the many conveniences of SPSS is its ability to 
import data from a spreadsheet accurately and efficiently. This ability makes SPSS 
particularly well suited and powerful for further analysis of data already in spreadsheet 
form. 
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Lesson 2 
The SPSS Main Menus and Toolbar 

 
After This Lesson, You Will Know 

• Each of the SPSS main menus and what the commands on the menus do 
• The icons on the toolbar 

 
Key Words 

• Analyze menu 
• Data menu 
• Edit menu 
• File menu 
• Graphs menu 
• Open dialog box 
• Status Bar 
• Toolbar 
• Transform menu 
• Utilities menu 
• View menu 
 
Menus are the key to operating any Windows or Mac application, and that is 

certainly the case with SPSS. Its 10 main menus (including the standard Windows and 
Help menus for the Windows version and the Help menu for the Mac version) provide 
access to every tool and feature that SPSS has to offer. In this lesson, we will review the 
contents of each of these menus and introduce you to the toolbar, a set of icons that 
takes the place of menu commands. The icons make it quick and easy to do anything, 
from saving a file to printing a chart. 
The SPSS Main Menus 

SPSS comes to you with 10 main menus, as you see in the opening screen in Figure 
4.  

 

 
 

Figure 4 The 10 main SPSS menus 
 

While you think you may know all about the File menu and what options are 
available on it, stick with us through the rest of this lesson to see exactly what the File 
menu, and the other nine menus, can do for you. 
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The File Menu 

The purpose of the File menu (Figure 5) is to work with files. Using the options on 
this menu, you create new files, open existing ones, save files in a variety of formats, 
display information about a file, print a file, and exit SPSS. The File menu also lists the 
last few documents that were accessed (File _> Recently used files) , so you can quickly 
return to a previous document. 

 
Tip: Want to set the number of files that SPSS lists on the File menu? Click Edit→Options 
and change the value in the Recently used file list box. 
 

 
 

Figure 5 The File Menu 
 

For example, when it comes time to start working with the file named Teacher Scale 
Results, you would select Open from the File menu and then select the file name from 
the Open dialog box. You will learn more about this process in Lesson 7. 
 
The Edit Menu 

When it comes time to cut or copy data and paste it in another location in the 
current, or another, data file, you will go to the Edit menu. You will also seek out 
options on the Edit menu to search for data or text, replace text, and set SPSS 
preferences (or default settings). All these activities and more are found on the Edit 
menu shown in Figure 6. 
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Figure 6 The Edit Menu 
 

Tip: When items on a menu are dimmed, it means they are not available. 
 
For example, if you wanted to find what Mary Jones scored on test 1, you could 

search for “Mary Jones” and then read across the file to find her score on the variable 
named test 1. You would use the Find command on the Edit menu to search for that 
information. 

 
The View Menu 

Here’s a chance to customize your SPSS desktop. Using various commands on the 
View menu, you can choose to show or hide toolbars, Status bar, and grid lines in the 
Data Editor, change fonts, and use Value Labels. You can see these commands in Figure 
7. 

 

 
 

Figure 7 The View Menu 
 

Tip: If you use labels for your variables, make sure that the Value Labels option is checked on 
the Vie menu. Otherwise, you won’t see them at all. 
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For example, if we didn't want to use labels for variables, we would be sure that the 
Value Labels option was not selected (as it is in Figure 7). 
 
The Data Menu 

Variables and their values are the central element in any SPSS analysis, and you 
need powerful tools to work with variables. You have them on SPSS. On the Data menu 
you see in Figure 8, you can see commands that allow you to define and sort variables, 
work with templates, go to a specific case, merge and aggregate files, and weigh cases 
as you see fit. 

 
 

Figure 8 The Data Menu 
 

Tip: When a menu options is followed by three dots (called an ellipsis), clicking on that 
option opens an additional dialog box with other options. 
 

For example, if we want to insert a new variable after data has already been entered, 
this is the menu you would use and the Insert Variable options is the menu options that 
would be selected.  

 
The Transform Menu 

There will be times when a variable value needs to be transformed or converted to 
another form or another value. That’s where the commands on the Transform menu 
you see in Figure 9 come in handy. On this menu, you will find commands that allow 
you to compute new values, create a set of random values, recode values, replace 
missing values, and do more. 
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Figure 9 The Transform Menu 
 

For example, you could easily compute a new variable that represents the mean of a 
set of items using the Compute command on the Transform menu. 

 
The Analyze Menu 

Here’s the meat-and-potatoes menu! As you can see in Figure 10, there are 
17different options on the Analyze menu that lead to almost any statistical analysis 
technique you might want to use. These range from a simple computation of a mean 
and standard deviation to time series analysis and multiple regression. 

 
 

Figure 10 The Analyze Menu 
 

For example, if you wanted to determine if there is a significant difference between 
the average rating that Professor 6 received on a teaching evaluation form versus the 
average rating received by Professor 4, you could look to the Compare Means option on 
the Analyze menu. 

 
The Graphs Menu 

Want to see what those numbers really look like? Go to the Graphs menu where you 
can create bar, line, area, and some 16 other types of graphs. Graphs make numbers 
come alive, and you should pay special attention to later lessons where we show you 
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how to create, edit, and print them. Take a look at Figure 11 (at the top of page 9) to see 
what graph options are available. 

 

 
 

Figure 11 The Graphs Menu 
 

For example, if you want to see test scores as a function of gender, a bar graph (on 
the Graphs menu) could do it quite nicely. 
The Utilities Menu 

Here you can find out information about variables and files, and you can define and 
use sets of variables. You can see these options in Figure 12 on the Utilities menu. 

 

 
 

Figure 12 The Utilities Menu 
 

For example, the File Info option (for File Information) on the Utilities menu can tell 
us that the file named Teacher Scores contains 50 cases and 8 variables. 
 
The Window and Help Menus 

These two menus function much like any other Windows application menus. The 
Window menu helps you switch from one window to another and minimize the SPSS 
Data Editor or Viewer.  
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The Help menu provides online help. We will focus on the Help menu in the 
next lesson. 
 
The SPSS Toolbar and Status Bar 

What’s the easiest way to use SPSS? Clearly, through the use of the toolbar, the set 
of icons that are underneath the menus. You can see the Data Editor toolbar in Figure 13 
and a description of what each icon, which represents a command on an SPSS menu, 
does. Click on the icon, and the command is performed. So, instead of going to the 
Utilities menu to select variables, you can just click on the Variables icon on the toolbar. 
Table 1 presents the toolbar icon, it’s title and what it does. 

 

 
 

Figure 13 The Data Editor toolbar 
 

Different screens have different toolbars. For example, as you will see in Lesson 15, 
when you create a chart, a new set of icons becomes available on the toolbar. 
 
Tip: You can always find out what an icon does by placing the mouse cursor on top of it. A 
toolbar tip should popup. 
 

Another useful tool is the Status Bar located at the bottom of the SPSS window. 
Here, you can see a one-line report as to what activity SPSS is currently involved in. 
Messages such as “SPSS Processor is ready” tell you that SPSS is ready for your 
directions or input of data. Or, “Running Means …” tells you that SPSS is in the middle 
of the procedure named Means. 
 
The Data Files 

An important part of learning how to use SPSS and using this book, is using the 
sample files included on the student disk. Throughout Part I of the text, titled 
“Introducing SPSS,” we will use two separate sets of data to illustrate various SPSS 
features, such as entering and working with data. A detailed description of each of 
these files shown in Appendix A. 

 
Tip: If you are performing an analysis and nothing seems to be happening, look in the Status 
Bar before you panic and conclude that SPSS or Windows has locked up. Large numbers and 
complex analyses often take computer resources and time to complete. 
 
The Crab Scale File 

The first data set is a collection of scores on the Crab Scale and some biographical 
information for 10 college professors who completed a measure of crabbiness. Table 1 
gives a summary of the variables, their definition and their range of values. 
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Variable Definition Range 
id_prof professor’s identification number 1 through 10 
Sex_prof professor’s gender 1 or 2 
Age professor’s age 33 through 64 
Rank professor’s rank Assistant, Associate, or 

Full Professor 
School professor’s school Liberal Arts, Business 

School 
crab1 Score on item 1 on the Crab Scale  
crab2 Score on item 2 on the Crab Scale  
crab3 Score on item 3 on the Crab Scale  
crab4 Score on item 4 on the Crab Scale  
crab5 Score on item 5 on the Crab Scale  
crab6 Score on item 6 on the Crab Scale  

 
Table 1 

Crab Scale Summary 
 

The Crab Scale includes the following six items: 
1. I generally feel crabby if someone tries to help me. 
2. I generally feel happy when I watch the news. 
3. I generally feel crabby when I watch mothers and fathers talk baby talk to their 

babies. 
4. I generally feel happy when I am able to make sarcastic comments. 
5. I generally feel crabby when I am on a family vacation. 
6. I generally feel happy when I am beating someone at a game. 
A teacher responds to each item on the following 5-point scale: 
1. Totally agree 
2. Agree 
3. In a quandary 
4. Disagree 
5. Vicious lies 
The Crab Scale yields two scores: 
1. The Cross-Situational Crab Index: This index tries to assess whether individuals 

refuse to be happy regardless of the situation. 
2. The True Crab Scale: This index attempts to assess whether an individual is 

acting in a true crablike fashion: crabby when confronted with a pleasant 
stimulus and happy when confronted with an unpleasant stimulus. 

Items 1 through 6 are summed to yield a total score. For the Cross-Situational 
Crabbiness Index, all scores are summed together. Items 2, 4, and 6 are happiness items, 
and the scores on these items must be reversed so that higher scores indicate more 
crabbiness as shown here. 

Original Scoring Recoded Scoring 
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1    5 
2    4 
3    3 
4    2 
5    1 
You can see the actual set of data on your SPSS student disk as Crab Scale Results. 

 
The Teacher Scale File 
  No teacher escapes being rated by students. The second set of data we will 
deal with in Part I of Using SPSS for Analyzing and Understanding Data for Windows and 
the Macintosh is a set of responses by students concerning the performance of these 10 
professors. 

The second data set is a collection of scores on the Teacher Scale and some 
biographical information for 50 students who completed the Teacher Scale. Scores on 
the Teacher Scale that make up this sample file are also shown in Appendix A. They are 
contained on the student disk under the file name Teacher Scale Results. 

Table 2 shows the biographical information we collected on each student and their 
responses to the 5-point scale. We will be using them in examples throughout this part 
of the book. 
 

Variable Name Range 
id_stud student’s identification 

number 
1 through 50 

id_prof professor’s identification 
number 

1 through 5 

Sex_stud student’s gender 1 or 2 
teacher1 score for item 1 on the 

Teacher Scale 
1 through 5 

teacher2 score for item 2 on the 
Teacher Scale 

1 through 5 

teacher3 score for item 3 on the 
Teacher Scale 

1 through 5 

teacher4 score for item 4 on the 
Teacher Scale 

1 through 5 

teacher5 score for item 5 on the 
Teacher Scale 

1 through 5 

 
Table 2 

Teacher Scale Summary 
 

The Teacher Scale contains the following five items: 
1. I love that teacher. 
2. My teacher says good stuff. 
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3. The teacher has trouble talking. 
4. The teacher is a jerk. 
5. My teacher made the boring lively, the unthinkable thinkable, the undoable 

doable. 
Items 3 and 4 must be reversed so that higher scores indicate effectiveness as 

follows. 
Original Scoring  Recoded Scoring 
 1   5 
 2   4 
 3   3 
 4   2 

5 1 
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Lesson 3 
Using SPSS Help 

 
After This Lesson, You Will Know 

• About the contents of the SPSS Help menu 
• How to use the F1 function key for help 
• What Help options are available 
• How to use the Find option to search for particular words 
 

Key Words 
• Ask Me 
• Contents 
• F1 function key 
• Find 
• Help menu 
• Index 
• SPSS Help 
• Topics 
 
If you need help, you’ve come to the right place. SPSS offers help that is only a 

few mouse clicks away. It is especially useful when you are in the middle of creating a 
data file and need information about a specific SPSS feature. Help is so comprehensive 
that even if you’re a novice SPSS user, SPSS Help can show you the way. 

 
How to Get Help 

You can get help in SPSS in several ways. The easiest and most direct is by pressing 
the F1 function key or by using the Help menu. 

As you can see, there are seven options on the Help menu. 
• Topics list the topics for which you can get help. You can click on any one 

of these. As you enter the topic, SPSS searches its internal database to find 
what you need. 

• Tutorial takes you through a step-by-step tutorial for major SPSS topics. 
• SPSS Home Page uses your Internet connection to take you to the home 

page of SPSS on the Internet. Syntax Guide provides you with help using 
SPSS’ powerful syntax feature. 

• Syntax Guide provides you with information on SPSS programming 
language. (Note: this option does not appear in the Macintosh version of 
SPSS). 

• Statistics Coach walks you through the steps you need to determine what 
type of analysis you want to conduct. 

• About … tells you the version of SPSS that you are currently using. (Not 
for the Mac!). 
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• Register Product … helps you register your copy of SPSS. (Not for the Mac 
here either). 

•  
Using the F1 Function Key 

The F1 function key is a quick way to get help, but it only opens the Help Topics 
dialog box you see in Figure 14. It is not context sensitive. In other words, it produces 
the same outcomes as the Help→Topics click combination. Here, you can click 
Contents, Index or Find. 

 

 
 

Figure 14 The F1 Help options 
 
Using the Topics Option 

The Topics option on the SPSS Help menu provides an alphabetical listing of 
help topics by Contents, an Index option, and the Find option. 
 
Using the Contents Option 

The Contents tab presents the major headings for help. Double-clicking on any one 
provides a list of possible topics that you might want to consult for the help you need. 
For example, if you want help on how to compare the means of two samples, you 
would follow these steps: 

1. Press F1. 
2. Click the Contents tab. 
3. Double-click Statistical analysis, and you will see a list of the topics within 

this general heading. 
4. Double-click the topic labeled Compare Means. 
5. Double-click the topic labeled Independent-Samples T Test procedure. You 

will see Help, as shown in Figure 15. 
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Figure 15 Getting Help on a particular procedure using the Contents Tab. 
 

Other tabs in the Help Topics dialog box are as follows: 
• The Index tab, when clicked, lists all the SPSS topics in alphabetical order 
• The Find tab, when clicked, allows you to search for a topic on which you 

need help. 
 
Tip: Once you find help on the subject you want (such as information about the mean), you 
can click on the Options button in the Help window (or right-click anywhere in the window) 
and perform a variety of tasks. For example, you can annotate the Help screen with your own 
information, copy the Help content to the clipboard, print out the content of the Help menu, 
change the size of the fonts of the Help windows, or change the position of Help on the screen. 
 
Using the Index Option 

The Index tab provides an alphabetical listing of all the topics in SPSS. To find help 
on a particular topic, follow these steps. For example, here’s how you could use the 
Index option to find help on means. 

1. Click Help→→→→Topics. 
2. Click the Index tab. 
3. Type mean. 
As you enter the letters of the term for which you need help, SPSS Help tries to 

identify the topic listing. You can then get help by clicking on any topic within the more 
general topic of mean. In Figure 16, you can see the definition of the mean, one of the 
options available in the Help window. 
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Figure 16 The definition of the mean obtained through the use of the Index tab. 
 
Tip: Many Help screens include a How To button, which walks you through the actual steps 
to complete the process or analysis you want to perform. 
 
Using the Find Option 

What if you can’t find a term in the Index, but you need help anyway? The Find 
option in the Help Topics dialog box allows you to enter any words that may be part of 
a Help screen rather than just a category. In effect, you are searching all the words in all 
the topics. 

For example, let’s use the Find option and the term “variance” and see what SPSS 
delivers. Follow these steps. If the Help window is opened, close it now. 

1. Press F1. (If you are using the Mac version then you have click Help →→→→ 
Topics). 

2. Click the Find tab. 
3. Type “variance,” and SPSS returns a list of topics for which the word is 

relevant. (For the Mac version, you have to click the Search button).  
In Figure 17, you can see the topics related to the word “variance” for which you 

can get additional help by double-clicking on any of the items.  
 

 
 

Figure 17 Using the Find feature 
 
The Find feature is very sensitive to what words you select. For example, if you 

need help on the word “mean,” SPSS will turn up lots of references since the word 
(as written) is the most general. The word “Mean,” however, is more specific, and 
the word “MEAN” even more so (since MEAN is the specific procedure in SPSS 
syntax). If you know exactly what you’re looking for, you can be specific, but be 
careful because specificity can cause you to miss what you are looking for if you are 
not sure of your topic’s exact terminology. 
 
Tip: Click on the How To or See Also buttons to get step-by-step instructions on how to 
complete the procedure you need help on or to get additional help. 
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Options in Any SPSS Help Window 

Within any one of the SPSS Help windows, (such as the one you see in Figure 15) 
there are various other options you can use.  
 
Tip: Using the Print option in Help allows you to print items that you may frequently need 
to refer to and to keep the hard copy organized for easy reference. 
 

• The Contents button returns you to the list of topics in Help (see Figure 
14). 

• The Index button returns you to the Index. 
• The Back option takes you back to the previous Help screen. 
• The Print option prints out the contents of the Help window. 
• The Options option provides the various options mentioned earlier in this 

lesson, such as copy and annotate. 
• The How To option provides a step-by-step description of how to perform 

the procedure. 
• The See Also option provides additional topics. 

 



 

 20 

Lesson 4 
A Brief SPSS Tour 

 
After This Lesson, You Will Know 

• How to open a file 
• Some of the basic functions that SPSS can perform 

 
Key Words 

• Fonts 
• Open 
 
In the first three lessons of Using SPSS…, you learned how to start SPSS, took a 

look at the SPSS main menus, and found out how to use SPSS Help.  
Now, sit back and enjoy a brief tour of SPSS activities. Nothing fancy here. Just 

creating some new variables, simple descriptions of data, a test of significance, and a 
graph or two. What we’re trying to show you is how easy it is to use SPSS. We will 
spend all of Part II of Using SPSS… concentrating on exactly how to use SPSS’ analytic 
procedures. 

 
Opening a File 

You can enter your own data to create a new SPSS data file, use an existing file, or 
even import data from such applications as Microsoft Excel into SPSS. Any way you do 
it, you need to have data to work with. In Figure 18 you can see we have a screen full of 
data, part of the Teacher Scale Results file mentioned earlier and available on the disk 
that accompanies this book. We opened it using the Open option on the File menu. 

 

 
 

Figure 18 Opening a File 
 
If you use a spreadsheet application, then the structure of the data file appears 

familiar; it has rows and columns, with cases for rows and variables for columns. 
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Working with Appearance 
Everyone has his or her preference on how things look. In Figure 18, the data appear 

in a sans serif font named Arial and 12 points (with one point being equal to 1/72 of an 
inch) in size. For whatever reason, you may want to select another font and change the 
style in which the values or headings appear. 
 
Tip: If you want to open saved output, then you have to select the Output option on the  
File →→→→ Open menu, or the Syntax or Script option or whatever you want to open. 
 

Simply by using the Fonts option on the View menu, we changed the font to Times 
New Roman 10 point. We also used the Grid Lines option on the View menu to turn off 
the grid lines. The partial screen showing the data file appears in Figure 19. 
 

 
 

Figure 19 Changing the appearance of data 
 
Tip: A quick way to change the appearance of data in the Data Editor is to right click in any 
cell and click Grid Font. Then select the font, size and style. 
 
Creating a New Variable 

As you know, the Teacher Scale is a five-item measure of teacher effectiveness. Let’s 
assume that we want to compute a new variable that is the average of the five items, so 
that each student’s ratings have an average score. 

To create a new variable, we use the Compute option on the Transform menu. The 
finished result (the new variable named average) is shown in Figure 20. 

 
 

 
 

Figure 20 Using the Compute Command to create a new variable 
 
A Simple Table 

Now it’s time to get to the reason why we’re using SPSS in the first place, the 
various analytical tools that are available. First, let’s say we want to know the general 
distribution of males and females. That’s all, just a count of how many males and how 
many females are in the total sample. 
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In Figure 21, you can see an output window that provides exactly the information 
we asked for, which was the frequency of the number of males and females. We clicked 
Analyze→Descriptive Statistics→Frequencies to compute these values. We could have 
computed several other descriptive statistics, but just the count is fine for now. Here’s 
your first look at real SPSS output, contained in the Viewer window and the outline 
pane on the left which lists all the output available. 
 

 
 

Figure 21 A simple SPSS table 
 
Guess what? With just another few clicks, we can create the bar chart you see in 

Figure 22). This graph also shows the special graphing tools on the toolbar in the SPSS 
Chart Editor. Also, you should notice that as additional items are added to the Viewer, 
the outline pane to the left of the viewer lists those as well. There are lots of ways to jazz 
up this graph, many of which we will discuss in Lesson 16. 

 

 
 

Figure 22 A simple SPSS chart 
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A Simple Analysis 
Let’s see if males and females differ in their average Teach scores. This is a simple 

analysis requiring a t test for independent samples. You may already know about this 
procedure from another statistics class you have had, or it may be entirely new. The 
procedure is a comparison between the mean for the group of males and the mean for 
the group of females. 

In Figure 23, you can see a partial summary of the results of the t test. Notice that the 
listing in the left pane of the Viewer now shows the Frequencies, Graph, and T-Test 
procedures listed. To see any part of the output, all we need to do is click on that 
element, in the left pane of the Viewer, as we did with Frequencies. The large arrow 
(which appears in red on the screen) indicates which of the various outputs you have 
highlighted in the output pane.  

 

 
 

Figure 23 A simple SPSS analysis 
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Lesson 5 
Defining Variables 

 
After This Lesson, You Will Know 

• How to open a new data file 
• How to define an SPSS variable’s characteristics 

 
Key Words 

• Column 
• Row 
• Variable View window 
• Data View window  
• Variable information bar 
 
Here’s where all the work begins, with the entry of data into the SPSS spreadsheet 

like structure, the Data View (as you saw in Figure 18). When you first open SPSS, the 
Data Editor window is labeled Untitled - SPSS Data Editor, and it’s ready for you to 
enter variables as well as cases. You can just begin entering data in Row 1, Column 1 
and as you can see in Figure 24, SPSS will record that as the first data point for var00001 
(which SPSS will automatically name the column or variable). In SPSS, rows always 
represent cases and columns always represent variables. 

 

 
 

Figure 24 Entering Data in Data View Window 
 
Creating a SPSS New Window 
 If you are already working within SPSS and want to create a new Data View 
window, follow this step. 

1. Click File →→→→ New→→→→ Data. You will see a blank Data View window and you are 
ready to either define or enter data. 

 
Having SPSS Define Variables 

Now that the new data window is open, you can do one of two things. The first is to 
enter data into any cell in the Data View Window and press the Enter key (which is the 
standard way of entering data). For example, you could enter the value 87 in row 1, 
column 1 and press the Enter key. Since SPSS must have a variable name to work with, 
SPSS will automatically name the variable var00001. If you did this in row 1, column 5, 
then SPSS would name the variable var00005 and also number the other columns 
sequentially, as you see in Figure 25. 
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Figure 25 SPSS can automatically define variables. 
 
Note also that right below the main menu in the upper left-hand corner of the Data 

View window is an indicator of what cell is being highlighted. For example, in Figure 
25, you can see that 1:var00005 represents row 1, variable 5. 
 
Custom Defining Variables: Using The Variable View Window 
 However, a critical part of dealing with data is defining those variables that you 
intend to enter. And by defining, we mean everything from providing a name for the 
variable (or the column in the Data View window), the type of variable it is, how many 
decimal places it will use and so forth.  
 In order to define a variable, one must first go to the Variable View Windows by 
clicking the Variable View tab at the bottom of the SPSS screen. Once that is done, you 
will see the Variable View window as shown in Figure 26 and be able to define any one 
variable as you see fit. 
 

 
 

Figure 26 The Variable View Window 
 
Tip: With previous versions of SPSS, you could right click on a column in the Data Editor 
window and then define a variable. Not so with version 11. All definitions have to take place 
in the Variable View window. 
 
 Once in the Variable View window, you can define variables along the following 
parameters: 
 

• Name provides a name for a variable up to eight characters 
• Type defines the type of variable such as text, numeric, string, scientific notation, 

etc. 
• Width defines the number of characters wide the column housing the variable 

will occupy. 
• Decimals define the number of decimals that will appear in the Data View. 
• Label defined as a label up to 256 characters for the variable 
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• Values defines the labels that correspond to certain numerical values (such as 1 
for male and 2 for female). 

• Missing indicates how missing data will be dealt with. 
• Columns define the number of spaces allocated for the variable in the Data View 

window. 
• Align defines how the data is to appear in the cell (right, left or enter aligned 
• Measure defines the scale of measurement that best characterizes the variable 

(nominal, ordinal, or interval). 
 
 The general way in which these characteristics of a variable are defined is by 
clicking on the cell for that particular variable (variable 1, variable 2, etc.) and then 
specifying the particulars of those characteristics for the variable under question. 

Each of these is described as follows. We use the file named Crab Scale Results 
and discuss how we defined these available. The Variable View of their file is shown in 
Figure 27. 

 

 
 

Figure 27 The Variable View of the Crab Scale Results file 
 
Defining Variable Names 
 To define the name of a variable, follow these steps. 

1. Click on a cell in the Name column in the Variable View window. 
Press the Enter key. The name for the first variable was id_prof. 

 
Defining Variable Types 

If you click on a cell in the Type button, and the ellipsis in it (see Figure 27), you see 
the Variable Type dialog box. Its variable definitions include numeric (e.g., 3435.45), 
comma (e.g., 3,435.45), dot (e.g., align) (e.g., 3.43545), scientific notation (e.g., 3.4E+03), 
date (e.g., 12-FEB-1996), dollar (e.g., $3,435.45), custom currency (as you design it), or a 
string (such as William). In our example, all variables are defined as numeric. 

 

 
 

Figure 28 Defining the type of variable 
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Defining Variable Widths  
 To define the width of a variable, follow these steps. 

1. Click on a cell in the Width column for the corresponding variable (in the 
Variable View screen). 

2. Enter the number of characters you want to use to define the variable or click on 
the up and down triangles (see Figure 29) to change the value. 

 

 
 

Figure 29 Changing the width of a variable 
 

Defining Variable Decimals 
 To define the number of decimals used to define variable, follow these steps. 

1. Click on the Decimal column for the corresponding variable 
2. Enter the number of characters you want to use to define the number of decimals 

or click on the up and down triangles to change the number in the cell. 
 
Defining Variable Labels 
To define the Label used for a variable, follow these steps. 

1. Click on the Label column for the corresponding variable. 
Enter the up to 256 characters for the label, including spaces. Labels appear in SPSS 

output and are not visible in the Data View window. Of example, in Figure 27, you can 
see how the variable named sex_prof is accompanied by the label Sex of Teacher. 
 
Defining Variable Values 

Values are used to represent the contents of a variable in the Data View window. For 
example, we will show you how we defined the sex of the teacher using 1’s and 2’s and 
3’s for the variable named rank, while those 1’s and 2’s and 3’s appear as assistant, 
associate and full professor in the Data View window.  

In general, it makes more sense to work with numbers than with string or 
alphanumeric variables in an analysis. In other words, values such as 1 for assistant 
professor, 2 for associate professor, and 3 for full professor provide more information 
than the actual text that describes the levels of the variable named rank. 

Just the same, it sure is a lot easier to look at a data file and see words rather than 
numbers. Just think about the difference between a data file with numbers representing 
various levels (such as 1, 2, and 3) of a variable and the actual values (such as assistant 
professor, associate professor, or full professor).  

To define the Values used for a variable, follow these steps. 
1. Click on the Values column for the corresponding variable. In this case, we are 

using rank as the example. 
2. Click on the ellipsis to open the Value Labels dialog box as shown in Figure 30. 
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Figure 30 The Value Labels dialog box 
 

3. Enter a value for the variable. This is what will appear in the data file 
window, such as 1, 2, or 3. 

4. Enter the value label for the value such as assistant, associate or full. 
5. Click Add.  
6. Click Continue. When you finish your business in the Define Labels dialog 

box, click OK, and the new labels will take effect. 
 
Tip: Once a variable is defined, you can easily change the value by just clicking on the arrow 
of a highlighted cell in the Data View. 
 
Defining Missing Values for a Variable 

To define the Values used for a variable, follow these steps. 
1. Click on the Missing column for the corresponding variable 
2. Click the ellipsis and you will see the Missing Values dialog box. The various 

options you can select are as follows. 
• The No missing values option treats all values as being valid, such that 

no missing values are present in the data file.  
• The Discrete missing values option allows you to enter up to three 

values for a missing variable.  
• The Range plus one discrete missing value option will identify as 

missing all the values between the low and high values you identify, 
plus one additional value outside the range. 

 
Defining Variable Columns 

To define the variable Columns Values follow these steps. 
1. Click on the Columns column for the corresponding variable 
2. Enter the value you want for the width of the column or click on one of the up or 

down triangle to set the width. 
 
Tip: Don’t confuse variable width and variable columns defining characteristics. Width 
refers to the number of characters used to define the display in the Data View window. 
Columns refers to the number of columns used to define the variable.  
 
Tip: To change the width of a column (in the Data View or Variable View windows), you can 
drag on the vertical lines that separate the columns from one another. 



 

 29 

 
Defining Variable Alignment 

To define the alignment used for a variable, follow these steps. 
1. Click on the Align column for the corresponding variable. 
2. From the drop down menu, select Left, Right or Center. 

] 
Defining Variable Measure 

To define the Measure used for a variable, follow these steps. 
1. Click on the Measure column for the corresponding variable. 
2. From the drop down menu, select Scale, Ordinal or Nominal as the level of 

measurement you want to use for this variable. 
In sum, we have defined 11 different variables as shown in Figure 27. Each has 
particular setoff characteristics and any of these can be changed quickly and easily 
be clicking on the Variable View window tab and then changing the variable 
attribute you want. 
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Lesson 6 
Entering and Editing Data 

 
After This Lesson, You Will Know 

• How to enter data into an SPSS Data Editor window 
• About editing data in SPSS 

 
Key Words 

• Active cell 
• Save File As dialog box 
• Save Data As dialog box 
 
You just learned how to define a set of variables. Now it’s time to enter data that 

correspond to the set of variables. We’ll also learn how to edit data. The file that you 
will create is already on your SPSS work disk and is named Lesson 6 Data File 1. It 
consists of 10 cases and three variables (id, sex, and test1), and you can see what it looks 
like in Figure 31. 

 

 
 

Figure 31 A simple data file 
 
Getting Ready for Data 

Let’s start at the beginning. First, we’ll define each of the three variables in the data 
file you see in Figure 31. Start with an empty Data Editor window. 

1. Click the Variable View tab in the opening window. 
2. In cell 1, row 1, type the variable name id. 
3. Press the Enter key and you will see SPSS complete the default definition for 

each of the variables characteristics. 
3. In cell 1, row 2, type the variable name sex. 
4. Press the Enter key and you will see SPSS complete the default definition for 

each of the variables characteristics. 
4. In cell 1, row 2, type the variable name test. 
5. Press the Enter key and you will see SPSS complete the default definition for 

each of the variables characteristics. Each row (representing a variable) 
should contain the information necessary to define three variables; id, sex, 
and test as you see in Figure 32. 
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Figure 32 Defining three variables 
 

6. Click on the Data View tab to return to the Data Editor window as you will 
see the three variables defined as shown in Figure 33. 

 

 
 

Figure 33 Waiting for data entry 
 
Entering Data 

Entering data into the Data Editor window and creating a data file is as simple as 
entering data in a spreadsheet or creating a table using a word processor. You just click 
in the cell where you want to enter data (which then appears as outlined), click, and 
type away. Let’s enter data for the first case. 

1. Place the cursor on row 1, column 1. 
2. Click once. The cell borders of the individual cell in the data file will be 

outlined. 
3. Type 1 for id 
4. Press Tab to move to the next variable in the current case. You can also press 

the down arrow (↓ ) key to move to the next case within the same variable. 
SPSS will enter the value 1.00 since the default format is two decimal places. 
The next cell in the row will then be highlighted. You’ll notice that as you 
enter values into cells in the Data Editor the value appears in the data entry 
information bar right above the column headings. 

The cell in the Data Editor that is highlighted and that shows the value in the 
information bar is the active cell. In Figure 34 the active cell has a value of 1. 

 

 
 

Figure 34 Entering the first data point in the Data Editor. 
 

5. Type 1 for sex. 
6. Press the tab key to move to the column labeled “test1.” The Shift+Tab key 

combination moves one cell to the left. 
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7. Type 45. To get to the next case, press the Home key and the down arrow (↓ ) 
key. Compare your Data Editor to the one you see in Figure 34 to be sure you 
are entering data in the correct locations. 

8. Continue entering data in the Data Editor until all the data you see (all 10 
cases) are entered. 

If you make an error, just backspace. Or, just don’t worry about it! You will learn 
how to correct such errors in the next section in this lesson. 
 
Editing Data 

Editing data in a data file is simply a matter of locating the data you want to edit 
and then changing them. There are several techniques you can use to do this including a 
simple click and edit or cutting and pasting. You’ll learn about them all in this part of 
the lesson. 
 
Changing a Cell Value 

Let’s say that you want to change the value of test1 for case 3 from 44 to 54. You 
made an error in data entry and want to correct it. Here’s how. 

1. Click on the cell you want to change, which in this case is the cell in test1, case 
3 with a value of 44. When you click on the cell, its value will appear in the 
data information bar or the cell editor area. 

2. Type 54. As you begin typing the new value, it replaces the old one. 
3. Press Enter. The new value is now part of the data file. 

 
Tip: As with any Windows operation, double-clicking on the contents of a cell selects all the 
material in that cell. You can just double click and type the replacement. 
 
Editing a Cell Value 

You can also edit an existing value without replacing it. For example, you may want 
to change the test1 value for case 1 from 45 to 40, and you just want to change the last 
digit rather than replace the entire value. Here’s how. 

1. Click the cell containing the value you want to edit. In this case it is the cell 
for test1, case 1, which contains the value 45.  

2. Click to the right of the last digit in the data entry information bar. A blinking 
horizontal line will appear in the cell editor following the last digit of the cell 
entry. 

3. Backspace once to delete the 5. 
4. Type 0. 
5. Press Enter or move to another cell. The new value is now part of the data 

file. 
If you wanted to change a value such as 4565 to 4665, you would use the mouse 

pointer to insert the blinking cursor between the first 5 and the 6, press the backspace 
key once, and then enter the new value. If you wanted to insert a value in an existing 
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one (such as changing 198 to 1298), you would place the cursor where you want the 
new values to be inserted and just enter them. 
 
Saving a Data File 

This is the easiest operation of all, but it may be the most important. As you know 
from your experience with other applications, saving the files that you create is 
essential. First, saving allows you to recall the file to work on at a later time. Second, 
saving allows you to back up files. Finally, you can save a file under a new name and 
use the copy for a purpose different from the original purpose. 

Don’t wait to save until your data file is entered and you are sure there are no errors. 
Why should you save a file before it is entered exactly as you want it? It’s a matter of 
being “safe rather than sorry.” 
 
Tip: How often should you save? You should save after a set amount of work (either time or 
pages worth). One general rule is to save as often as necessary so that you can easily recreate 
any work you might lose between saves—every time you finish entering 10 cases or after 30 
minutes of work might be a good starting guideline. 

 
When you are creating a data file document (and before you save it for the first 

time), the only “copy” of it is stored in the computer’s memory. If, for some reason, the 
computer malfunctions or the power (and the computer) goes off, whatever is stored in 
this temporary memory will be lost. It literally disappears, whether it is a data file with 
three variables and 10 cases or 300 variables and 10,000 cases. Save data files as you 
work! 

Before saving a file for the first time, however, the first order of business is deciding 
on a name for the file. 

To save a data file, you must assign a unique file name to it. For example, if you 
were to name a file “data” you might find it confusing, because you will surely be 
creating more than one file, and “data” describes virtually all of them. Also, should you 
try to save a file to a directory containing an identically named file with different 
contents, the new file will overwrite the original file. You lose the original file and all 
your work.  

For these reasons, use a name that describes the contents of the data file. SPSS also 
automatically attaches the .sav extension to all saved files.  

With Windows, file names can be up to 225 characters long, so you shouldn’t have 
any difficulty being sufficiently descriptive, although being wordy has problems, too. 
Try to find a middle ground between describing the file and not having a name so long 
that it can’t easily fit on the screen. 

To save the data document that is active (which has the data you entered, as you 
saw in Figure 31), follow these steps: 

1. Click File →→→→ Save. When you do this, you will see the Save Data As dialog 
box which you should be familiar with by now. 
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2. Select the directory in which you want to save the data. If you are saving to a 
hard drive and you are working in a computer lab, be sure you have 
permission. If you are saving to a floppy disk, select drive a or drive b. 

3. Enter the file name you want to use in the File Name text box to save the data 
that has been entered. We used Lesson 6 Data File 1. 

4. Click OK. 
The data you entered will then be saved as a data file, and the name of the file will 

appear in the title bar of the Data Editor window. The next time you select Save Data 
from the File menu, you will not see the Save Data As dialog box. SPSS will just save the 
changes under the name you originally assigned to the data file. And remember, SPSS 
will save the data in the active directory. In most cases, that will be the same directory 
that contains SPSS, a situation you may or may not want. 
 
Tip: You can have Windows hide file extensions by going to the Explorer, right clicking, 
selecting properties and asking Windows to hide extensions. 

 
The Save As option on the file menu allows you to save a file under another name or 

under another format. For example, if you select the Save As options, you can select 
from such formats as Excel and Lotus 2-3—very handy for exporting your SPSS file to 
another application. 

 
Tip: Unlike other Windows applications, you must first enter data before you can save the 
data as an SPSS file. SPSS will not let you save a blank Data Editor window. 

 
Saving a File in a New Location 

You can easily select any other location to save a file. Perhaps you want to keep the 
application and data files separate. For example, many SPSS users have a separate 
directory for each project. That way, files from different projects don’t get mixed 
together. Or, you may want to save a file to a floppy disk and then take the disk home 
for safekeeping. 

Here’s how to save a file to another location: 
1. Click File →→→→ Save As. You’ll see the Save Data As dialog box. 
2. Enter the name of the file in the File Name text box. 
3. In the Save In section of the Save As dialog box, click the directory where you 

want the file saved. For example, if you want to save the file to a disk in drive 
B, click [-b-]. 

4. Click OK, and the file is saved to the new location. 
You can save to any location by clicking a series of drives and directories.  

Opening a File 
Once a file is saved, you have to open or retrieve it when you want to use it again. 

The steps are simple. 
1. Click File →→→→ Open, and you will see the Open File dialog box as you see in 

Figure 35. 
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Figure 35 The Open File dialog box 
 

2. Find the file you want to open, and double-click on the file name to open it or 
highlight the file name and click OK. 
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Lesson 7 
Inserting and Deleting Cases and Variables 

 
After This Lesson, You Will Know 

• How to insert and delete a case 
• How to insert and delete a variable 
• How to delete multiple cases and variables 

 
Key Words 

• Insert 
• Delete 

 
More often than not, the data you first enter to create a data file need to be changed. 

For example, you may need to add a variable or delete a case. You learned in the last 
lesson how to enter and edit data and then save all the data as a data file. But the simple 
editing may not be enough. 

There are times when you want to add one or more cases, or even an entirely new 
variable, to a data set. A subject might drop out of an experiment and you may choose 
to delete a case, or for measurement or design reasons an entire variable may no longer 
be useful and need to be deleted from a data file. In this lesson, we will show you how 
to insert and delete both cases and variables. 

The SPSS file we’ll work with in this lesson is shown in Figure 36. It contains three 
variables (age in years, social class, and preference for soft drink) and five cases, and it 
is saved on the student disk as Lesson 7 Data File 1. 

 

 
 

Figure 36 Data File Lesson 7 Data File 1 
 
Inserting a Case 

Notice in Figure 36 that the cases are sorted by age in ascending order from the 
youngest subject (aged 44) to the oldest subject (age 67). Let’s say we want to add a new 
case. We’ll place it between the second and third cases. 
 
Tip: When inserting a case, you can select any cell in the row above which you want to insert 
the case. 
 

1. Select a cell in the row above which you want to insert the new case. In this 
example, it is row 3 since we want the new case to appear right above row 3. 
You can select any cell in the row. 
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2. Click Data →→→→Insert Case, or click the Insert Case button on the toolbar. As 
you can see in Figure 37 an entire new row opens up, providing room to enter 
the data for the new case. 

 

 
 

Figure 37  Inserting a case 
 

You’ll notice that when you add a case, dots appear in the blank cells indicating that 
there are missing data. Now you can enter the data that make up the new case. Enter 
any data you want. 
Inserting a Variable 

Now let’s say that you need to add an additional variable to the data file. For 
example, you want to add the variable weight in pounds so that it appears before the 
variable labeled “pref,” for preference. 

1. Select a cell in the column to the right of where you want to insert the new 
variable. We selected a cell in column 3 (labeled pref) since we want to insert 
a new variable just to the left of pref. 

3. Click Data→→→→Insert Variable, or click the Insert Variable button on the 
toolbar. As you can see in Figure 38, an entire new column opens up 
providing room to enter the data for the new variable. As you can also see, 
the new variable is automatically named by SPSS as var00001. 

 

 
 

Figure 38 Inserting a new variable 
 
You’ll notice that when you add a variable, dots appear in the blank cells, indicating 

that there are missing cases. You can define the variable (we named it weight) and enter 
the data for each case. The data file with a new case and variable added, and with data 
added as well, appears in Figure 39. 
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Figure 39 The edited data file 
Deleting a Case 

Now it comes time to learn how to delete a case that you no longer want to be part 
of the data file. For example, let’s delete the fourth case in the data file you now see in 
Figure 39. 

1. Click on the case number (not any cell in the row) to highlight the entire row 
as you see in Figure 40. 

 

 
 

Figure 40 Select a case to delete 
 

2. Click Edit →→→→ Clear. You can also press the Del key, or right-click and click 
Clear, and the case will be deleted.  

 
Tip: Oops! Inadvertently delete something? Select the Undo command on the Edit menu or 
use the Ctrl→Z key combination to undo the last action. 
 
Deleting a Variable 

We’re sure you know what’s next, deleting a variable. Needing to delete a variable is 
probably a rare occurrence; you would have thought through your data collection 
procedures well enough to avoid collecting data you don’t need. Nonetheless, the 
situation does arise. 
 
Tip: To delete more than one case or more than one variable, drag over the cases or variables 
and select them all and then press the Del key. 
 

For example, perhaps you find out after the fact that data you collected (such as 
social class) are confidential and cannot be used. You therefore need to delete the 
variable across all cases. Here’s how. 

1. Click on the variable or column to highlight the entire column. 
2. Click the Edit →→→→ Clear. You can also press the Del key, and the variable will 

be deleted, or right-click and click Clear 
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Lesson 8 
Selecting, Copying, Cutting, and Pasting Data 

 
After This Lesson, You Will Know 

• How to select data 
• How Cut and Copy and Paste can be used in a data file 
• How to cut and paste data 
• How to copy and paste data 
• What the clipboard does, and what its limitations are 

 
Key Words 

• Buffer 
• Clipboard 
• Copy 
• Cut 
• Paste 
 
This last lesson on editing a data file has to do with some Windows techniques 

that you may already be familiar with: selecting, cutting, copying, and pasting. In fact, 
these simple operations can save you time and trouble, especially when you want to 
move the value of one or more cells from one location to another, or to repeat columns 
or rows. 
 
Copying, Cutting, and Pasting 

With the Cut, Copy, and Paste tools located on the Edit menu, you can easily move 
cell entries (be it one or more cells) from one part of a data file to another part of the 
same data file. You can also move cell entries from one data file to another entirely 
different data file or even to another Windows application! 

In general, the steps you take to cut or copy and paste are as follows: 
1. Select the data you want to cut or copy by dragging over the data with the 

mouse pointer. It can be an individual cell, row, column, or more than one 
row or column. Rows and columns can also be selected by clicking on them at 
the top (for a column) or at the left (for a row). A range of cells defines a 
rectangular- or square-shaped set of cells. 

 
Tip: The Shift+arrow key combination can be used to select a range of cells as well. Click in 
an “anchor” cell, the use the Shift up, down, right or left arrows to select what you want. 
 

2. Click Edit→→→→ Cut or Copy. Unfortunately, unlike in other Windows 
applications, there are not cut, copy, and paste buttons on the toolbar. 

*3. Select the destination, or target cell, where you want the data pasted. The 
destination, or target cell, you select will act as the upper left-hand anchor if 
you are cutting or copying more than one cell. 
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4. Click Edit →→→→ Paste. 
The selected data will appear in the new location. Here is an example of cutting and 

pasting and copying and pasting. The data that we’re using, which you see in Figure 41, 
is contained in the file named Lesson 8 Data File 1 on the student disk. It consists of five 
cases of three variables (weight in pounds, height in inches, and strength ranking). 

 

 
 

Figure 41 Lesson 7 Data File 1 
 
Selecting Data 

Before you can cut, copy, or paste anything, you first have to highlight what you 
want to cut or copy. You are probably used to the most direct way of highlighting data, 
which is through the drag technique. For example, if you want to highlight a particular 
section of a data file, just drag the mouse pointer over that section. 

Thus, any set of data, cases, or variables can be highlighted by just dragging over the 
information using the mouse. An individual cell is automatically highlighted when you 
click on that cell. 

What if you’re not a mouser? Not to worry. Here’s an easy-to-use summary (Table 4) 
that will tell you how to use the keyboard to select any amount of text you want. 
 

Table 4 
Keyboard Strokes for Selecting 

 
To select Use these keys 
One cell down ↓  or the Enter key 
One cell up ↑  
One cell to the right → 
One cell to the left ← 
The first cell in a case Home 
The last cell in a case End 
The first case in a variable Ctrl + ↑  
The last case in a variable Ctrl + ↓  
An entire case Shift + Space 
An entire variable Ctrl + Space 
a block of cells Shift + ↑  or ↓  or ← or → 
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Cutting and Pasting 
Data are cut from a data file when you want to remove them from their original 

locations and paste them into another location. 
Here’s an example of cutting data to rearrange the order in which variables appear. 

We’ll be showing you this activity in Figures 42 and 43 where part of the data file is be 
copied to a new location. Specifically, we’ll move the height variable so that it is after 
strength. 

1. Highlight the data you want to cut as you see in Figure 42. In this example, 
we are highlighting the variable (and not just the data in that column) named 
height. Remember, when data are cut, they disappear from the original 
location. When you select, be sure to click on the variable name. 

 

 
 

Figure 42 Highlighting a variable to be moved 
 

2. Click Edit →→→→ Cut. When you do this, the variable height disappears from the 
Data View window. 

3. Move the insertion point to the location where you want to insert, or paste, 
the data. Click at the top of the column where the new variable name will 
appear so you highlight the entire column. 

3. Click Edit →→→→Paste. The data that were cut will then appear as you see in 
Figure 43. This is a pretty efficient way of getting data from one place to 
another. 

 

 
 

Figure 43 Pasting a variable in a new location 
 
Tip: When cutting, copying as pasting, SPSS has right-click features where you can 
highlight and then right click to select Cut, Copy or Paste. You can also use keyboard 
command to Copy (Ctrl+C), Cut (Ctrl+X), and paste (Ctrl +V). 

 
This is an example of cutting and pasting text within the same data file. Should you 

want to cut and paste between data files, the process is much the same. Here are the 
general steps. 

1. Highlight the data you want to cut and paste. 
2. Click Edit →→→→ Cut. 
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3. Open a new data file or the one into which you want the data pasted. 
4. Move the insertion point to the location where you want to insert, or paste, 

the data. 
5. Click Edit →→→→ Paste. Data will appear in the new location. 
In Figure 44, you can see the results of pasting them into a Windows Word Pad 

document. Notice that only the data and not the column headings are transferred. 
 

 
 

Figure 44 The results of cutting and pasting 
 
Copying and Pasting 

Copying data is not much different from cutting data, except that the data remain in 
their original locations. Copying is the ideal tool when you want to duplicate data 
within a document or between documents. 
 
Tip: Want to paste the same data in several locations? Just continue to select the Paste option 
from the File menu or the right-click menu. 

 
For example, the weight, strength, and height data may be part of one data file, and 

you want to copy only the first two variables (weight and strength) to a new data file. 
You will add additional variables and cases to the new file, but you want to preserve 
the original. 

The steps for copying and pasting are basically the same as cutting and pasting 
except for one different command. Here are the steps. 

1. Highlight the data you want to copy. Remember, when data is copied, the data 
remains where it was originally located. 

2. Click Edit →→→→ Copy. 
3. Move the insertion point to the target cell where you want to insert or paste 

the copied data. 
4. Click Edit →→→→ Paste. The data that were copied will then appear. 
A good use of copy and paste would be to copy data from a master data file that you 

want to use over and over, don’t want to change, and need to borrow from in the 
future. Using copy and paste will leave the master document intact while you copy 
what you need. 
 
Where Copy or Cut Data Go 

What happens to data that you cut or copy? When you cut or copy data, they are 
placed in a buffer, an area reserved for temporary memory. This buffer is called the 
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clipboard. The data are retrieved from the buffer when you select Paste. In fact, 
whatever information is in the buffer stays there until it is replaced with something else. 

For this reason you can paste the contents of the buffer into documents over and 
over again until something new has been cut or copied, replacing what was in the 
buffer. That’s why the Paste button is always darkened (or active) since it’s ready to 
paste whatever is in the buffer. 

Want to see the contents of the clipboard? Here’s how. 
1. Click Start →→→→ Programs →→→→ Accessories →→→→ Clipboard Viewer. You’ll see the 

current contents of the clipboard.  
It’s useful to remember some things about the clipboard. 
First, this buffer can hold only one thing at a time. As soon as you cut or copy 

something new, the new data replace whatever was first in there. 
Second, when you quit SPSS, the contents of the clipboard disappears. The clipboard 

is a temporary place so anything you want to save permanently, you should save to a 
file with a unique name.  
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Lesson 9 
Printing and Exiting an SPSS File 

 
After This Lesson, You Will Know 

• How to print a data file 
• How to print a selection from a data file 
• How to print output from an analysis or a chart 

 
Key Word 

• Print dialog box 
 
Once you’ve created a data file or completed any type of analysis or chart, you 

probably will want to print a hard copy for safekeeping or for inclusion in a report or 
paper. When your SPSS document is printed and you want to stop working, it’s time to 
exit SPSS. You probably already know the way to exit an application is not by turning 
off the computer! Rather, you need to give your application (and your operating 
system) time to do any necessary housekeeping (closing and ordering files, and so 
forth). In this lesson, we will show you how to print and safely exit SPSS. 
Printing with SPSS 

Printing is almost as important a process as editing and saving data files. If you can’t 
print, you have little to take away from your work session. You can export data from an 
SPSS file to another application, but getting a hard copy right from SPSS is often more 
timely and more important. 

In SPSS, you can print either an entire data file or a selection from that file. We’ll 
show you how to do both. 
Printing an SPSS Data File 

Let’s begin with data files. It’s simple to print a data file. 
1. Be sure that the data file you want to print is the active window. 
2. Click File →→→→ Print. When you do this, you will see the Print dialog box shown 

in Figure 45. 
 

 
 

Figure 45 The Print dialog box 
 
Tip: You can easily print a file with one click; just click the Print icon on the toolbar. 
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As you can see, you can choose to print the entire document or a specific selection 
(which you would have already made in the Data Editor window), and increase the 
number of copies from 1 to 9999 (that’s the limit). 

3. Click OK and whatever is active will print. 
Look at the printed output in Figure 46, and then read the comments below. 
 

 
 

Figure 46 SPSS Output 
 

First, you can see the title of the name assigned to the data file at the top of the page. 
In this case, it’s Lesson 9 Data File 1. This is a convenient reminder of what’s being 
printed. 

Second, a footer with the date and time and page numbers is automatically 
generated and printed at the bottom of the page. 

Third, the default is to print gridlines. If you do not want the grid lines to print, click 
Grid Lines from the View menu (so it is not checked) and the grid lines will not appear, 
either on screen or on the hard copy. If you want value labels printed, then select Value 
Labels from the View menu, and those labels will appear in cells, rather than the actual 
value you entered. 

Finally, the default for the orientation is to print in Portrait, which means the short 
edge of the paper is horizontal. If you want to switch to Landscape, you have to select 
Properties from the Print dialog box and then click Landscape on the Paper tab. 
 
Tip: The Properties dialog box (File →→→→ Print →→→→ Properties) allows youth do some pretty cool 
things. For example, you can print out put so that there are two or four pages on a sheet. 
Perfect for reviewing the results of an analysis before it is printed up for the final draft of an 
article or report. (Note: You will not find this dialog box in the Mac version). 
 
Printing a Selection from an SPSS Data File 

Printing a selection from a data file follows exactly the steps that we listed for 
printing a data file, except that in the Print dialog box, you click the Selection option in 
the Print dialog box. 
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1. Be sure that the data you want to print is selected (using the techniques we 
discussed in the last lesson). 

2. Click File →→→→ Print or click the Print icon on the toolbar. When you do this, 
you will see the Print dialog box. 

3. Click Selection if it is not already selected. 
4. Click OK, and whatever you selected will be printed. 

 
Printing from the Viewer Window 

When you complete any type of analysis in SPSS or create a chart, the results appear 
in the Viewer window. To print the output from such a window, follow exactly the 
same procedures as you did for printing any data file.  

Clicking OK in the Print dialog box will print all the contents of the Viewer. To print 
a selection from the Viewer, first make the selection by either clicking on the actual 
material in the right-pane of the Navigator, or clicking on the name of the material you 
want to print in the left pane of the Viewer. Then select the Print option from the File 
menu and click Selection in the Print dialog box. If the Selection option is dimmed in the 
Print dialog box, it means that you didn’t make a selection and, therefore, cannot print 
it.  
 
Tip: You can select more than one item from the Viewer by holding down the Crtl key as you 
select different output elements. 

 
Tip: The Page Setup menu on the File menu (when the Viewer is active) allows you a great 
deal of flexibility in printing out he contents of the Viewer window. You can set margins and 
orientation, and even click the Options button and create a highly customized header or 
footer.  
 
Exiting SPSS 

How do you end your SPSS session and close up shop for the day? Easy. 
1. Click File →→→→ Exit SPSS. SPSS will be sure that you get the chance to save any 

unsaved or edited windows and will then close. (Note: For the Mac, click File 
and then Click Quit.) 
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Lesson 10 
Exporting and Importing SPSS Data 

 
After This Lesson, You Will Know 

• How to export a data file to another application 
• How to export a chart to another application 
• How to import data from another application 

 
Key Words 

• Export 
• Import 
 
You already know how to open an SPSS data file by selecting Open from the File 

menu, locating the file, and clicking OK. But what if you created a file in another 
application, such as Excel or Lotus 2-3 or Word for Windows, and want to use that file 
as a data file in SPSS? Or what if you want to use an SPSS data file or a chart in a report 
you created with Word for Windows? Does that mean reentering all the data? Not at all. 
SPSS lets you export and import data, and in this lesson you will learn how to do both. 
 
Tip: You export data from SPSS to another application and import data from another 
application to SPSS. 
 
Getting Started Exporting and Importing Data 

When you export an SPSS data file, you are sending it to another application. Just as 
one country exports products to other countries, so you are exporting data from SPSS to 
another application. 

When you import data from another application, you are going to use it with SPSS. 
It may be a file created in Word or Excel or dBase. Just as one country imports products 
from other countries, so you are importing data from another application to SPSS. 
 
Tip: If you have trouble exporting a file created with another application to SPSS, try and 
convert the file to a text or ASCII file within the application where it was originally created. 
SPSS can more easily read ASCII files than any others. 

 
In general, the more commercially popular an application is, the more different 

types of data it supports. For example, Word can translate more than 30 different data 
formats. SPSS was designed for a more narrow audience than such a popular word 
processor, so fewer applications can directly read SPSS files. With the increasing 
popularity of SPSS and with the release of version 11 however, SPSS is more compatible 
with other applications than ever before. 
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Exporting Data 

Here’s just the situation where you would be interested in exporting data. You have 
been using SPSS to analyze data, and you want to use the results of the analysis in 
another application. To do so, you want to export data from SPSS. Let’s go through the 
steps of both exporting data, exporting an analysis of that data, and exporting a chart. 

Why might you want to export data? One good example is when you want to create 
an appendix of the raw data used in the analysis. You could just print the data file but, 
SPSS is limited in that you cannot use more than eight characters to name a variable or 
change the height of rows (or cases). You, however, want longer variable names or 
taller rows. So, you’ll export the data to Microsoft Excel, which has much greater 
flexibility in formatting. And since you are writing your report in Microsoft Word for 
Windows, an Excel-generated appendix is completely compatible. 

The first and most important thing to remember about exporting data to another 
application is the SPSS data must be saved in a format that the other application can 
understand. Fortunately, SPSS can save data files under a wide variety of formats. Just 
by examining Table 5, you can get a general idea as to what applications data files can 
be exported to. The SPSS data file must be saved using the appropriate extension for the 
application you are exporting to. 
 

Table 5 
Application Extension 

 
Application Extension 
SPSS .sav 
SPSS/PC+ .sys 
SPSS Portable .por 
Tab Delimited .dat 
Fixed ASCII .dat 
Excel .xls 
2-3 Release .sk1 (v3), .wk1 (v2), wks (v1) 
Sylk .slk 
dBase .dbf 
 
(Note: The Mac version also has an SPSS 7.0 and dBase IV, III, and II options). 

Let’s go through some examples, beginning with exporting the file we named 
Teacher Scale Results to Excel for Windows. 

1. Be sure the data file you want to export is active. 
2. Click File →→→→ Save As. 
3. In the “Save as type” area type scores, select the format used by the 

application you are exporting to. When you make the selection, the file 
extension changes. In this example, it would be .xls (for Excel). Be sure to 
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provide a name for the new file. In this case, it is scores, and the file will be 
saved as scores.xls. 

4. Click OK. A new file is created under the file name scores.xls, which can now 
be read by Excel. When you do export a file, SPSS confirms the export by 
giving you a message Internet he Viewer window regarding the number of 
variables and number of cases exported. It’s a nice confirmation. 

5. Open Excel. 
6. In Excel, click File →→→→ Open. 
7. Open the new exported file. Excel displays the file as shown in Figure 47. 

 

 
 

Figure 47 An SPSS file exported into Excel 
 
What if the application you want to export data into is not listed in the above table? 

Almost every application can read Tab Delimited or Fixed ASCII data. For example, 
let’s say you wanted to export an SPSS data file into Word for Windows (which saves 
files with a .doc extension). You could save it as a Tab Delimited file, and then have 
Word read it, as we did in Figure 48). Now, it “ain’t purty,” but the information is all 
there. With some changing of font size and spacing, it could appear quite nice and fit 
well into any document. 

 

 
 

Figure 48 Importing a tab delimited file 
 
SPSS has some pretty terrific charting features. You saw what an SPSS chart looks 

like in Lesson 4, and you’ll learn more about them later in Part I of Using SPSS… It 
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won’t be uncommon for you to need to create a chart and export it into another 
application. Let’s export a graph into a Word file. 

1. Create the graph you want to export. Be sure it is active. 
2. Click on the actual graph in the right pane of the Viewer. When the graph is 

selected and ready to be exported, it will be surrounded with a thin black 
line. 

3. Click Edit →→→→ Copy, or right-click, and click then Copy or Copy objects 
(depending upon the application). 

4. Open the application into which you want to export the chart. In this 
example, the application is Word. 

5. Click File →→→→ Paste or Paste Special (depending upon the application), or 
right-click, and then click Paste. The chart should appear in the new 
document.  

 
Exporting the Results of SPSS Output 

Here’s the situation. You’ve just done a simple t-test using SPSS, and you want to 
export the results of that analysis into another document. In effect, output is treated just 
like text. It can be cut or copied and pasted, and exporting output is identical to what 
you just did with a chart. 

Why retype all that information when you can just paste it right in? Here’s how. 
1. Run the analysis you want. 
2. Right click on the output you want to export in the right pane of the Viewer. 
4. Click Edit →→→→ Copy, or right-click, then click Copy or Copy objects depending 

the how you want the format of the copied results to appear. If you chose 
Copy, then the contents of the output will be copied, without any special 
format and these contents can be edited. If you chose Copy objects, then the 
exact format you see in the output will be copied. The two are show in Figure 
49 with the results of the simple Copy command shown above the results of 
the Copy objects command. 

5.  
 

 
 

Figure 49 Using the Copy and Copy objects commands when pasting a chart into 
another application. 
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Tip: SPSS creates objects as output and cannot be directly edited when exported. They need 
to be edited within SPSS or exported using the simple copy command. 

 
4. Open the document into which you want to paste the output. 
5. Click Edit →→→→ Paste, or right-click, and then click Paste. 
Here’s an important caution, however. If you copy results as an object, then you will 

not be able to edit it in the new application. An object is a bit-mapped image, much like 
a picture. If you simply copy them (and not use the Copy objects option), the data will 
be exported as text and you can edit it, but it will lose it’s original format. The best 
advice? Make your SPSS results to be exactly as you would like (by double-clicking on, 
editing the table within SPSS) them to appear and then copy them as an object. 
Importing Data 

Here’s the situation. You are a user of Excel or Lotus 2-3 and you’ve entered your 
data into one of these spreadsheets. Or perhaps you choose to enter your data into one 
of the many word processors available, such as Word for Windows or WordPerfect. 
Now you want to analyze the data using SPSS. 

This might be the situation if you did not have access to SPSS when it came time to 
enter the original data or if you just feel more comfortable using some other application 
to enter data. 

1. Click File →→→→ Open. 
2. Locate the file you want to import, highlight it, select the type of file it is from 

the drop-down file type menu and then click OK. When you do this, you will 
see the data in the SPSS Data Editor window appearing exactly as it would if 
you entered directly into SPSS.  

Just as you can export from SPSS to other applications, so you can import from a 
variety of different applications. A word of caution, however. Even though SPSS can 
read certain file formats (such as .xls for Excel files), it may not mean that SPSS can read 
the latest version of Excel. Revisions of many products occur soften it is impossible for 
them all to stay synchronized as far as versions are concerned. So, before you start 
entering loads of data to import, check to see if it’s even possible. 

The most important thing to remember about exporting and importing is finding the 
right format. You need to save a file in the right format so it can easily be exported or 
imported. Almost any set of data can be imported and exported as an ASCII file. When 
you want the data to remain intact as far as format and such, you’ll have to look for a 
different format and experiment to see which format works best. At the very least, you 
should be able to simply select the data and import or export it to and from SPSS using 
the Copy and Paste commands available on the main menu and when you right-click. 
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 Lesson 11 
Finding Values, Variables, and Cases 

 
After This Lesson, You Will Know 

• How to find variables, cases, and values 
• How to find text 

 
Key Words 

• Case 
• Case sensitive 
• Go To Case dialog box 
• Search for Data dialog box 
• Value 
• Variable 
• Variables dialog box 
 
Just imagine you have a data file that contains 500 cases and 10 variables. You 

know that the entry for age (one of the 10 variables) for case 147 was entered 
incorrectly. You can either scroll down to find that case or use one of the many find 
tools that SPSS provides. We’ll go through those tools and how to use them in this 
lesson. 
 
Finding Things 

Before we begin showing you how to find things, let’s pause for a moment to 
distinguish among variables, cases, and values. Even if we’ve covered some of this 
before, it’s a good idea to see all of it in one place. 

A value (also called a cell entry) is any entry in a cell, or the intersection of a row 
and a column. Values can be numerical such as 3, 56.89 or $432.12, or alphanumerical or 
text such as Sam, Sara, or Julie. 

A variable is something that can take on more than one value. Age, weight, name, 
score on test1, and time measured in seconds are all variables. Variables are defined in 
SPSS by columns. 
 
Tip: Any search operation requires you to enter the search information in a dialog box, which 
may block your view of the data editor. You’ll have to move the dialog box to view the results 
of the search. Do this by dragging on the title bar. 

 
A case is a collection of values that belong to a unique unit in the data file, such as a 

person or a teacher or a school. Cases are defined in SPSS by rows. 
With a small data file, you can just eyeball what is on the screen to find what you 

need. With a large data file, however, you could spend a good deal of time trying to 
find a case or variable, and even more time trying to find a particular value. If you have 
10 variables and 500 cases and no missing data, you have 5,000 cell entries (all of which 
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are values). Trying to find a particular one could take all day! Thus, the SPSS features 
that can find variables, cases, and values are most welcome. 
 
Finding Variables 

For the example in this lesson, we’ll use the data file named Crab Scale Results on 
the student disk. Open that file now. We’ll find the variable named rank. 

1. Make sure the data file is active. 
3. Click Utilities →→→→ Variables. When you do this, you will see the Variables 

dialog box, as shown in Figure 50. 
 

 
 

Figure 50 The Variables dialog box 
 

3. Click Rank. The Variables dialog box provides a good deal of information 
about the variable, including its name, label, type, missing values that are 
included, and value labels (Assistant Professor, etc.). 

4. Click Go To, and SPSS will highlight the first cell in the column containing 
the variable. 

You’re now ready to perform any type of operation on that variable, such as 
working with labels, transformation, recoding, and more. 
 
Finding Cases 

Now that you know how to find any variable in a data file, it’s time to see how you 
can find any case. In the Crab Scale Results example, let’s assume that you need to 
locate case 8. You can do that by scrolling through the data file, which is simple enough. 
If the cases number in the hundreds, however, it’s not so simple a task. To save you 
time and trouble, SPSS finds cases like this. 

1. Click Data →→→→ Go To Case. When you do this, you will see the Go To Case 
dialog box, as shown in Figure 51. 

 

 
 

Figure 51 The Go To Case dialog box 
2. Type 8. 
3. Click OK. SPSS will highlight the row corresponding to the number you 

entered, for whatever column or variable the cursor is currently located in. 
For example, if we just found the variable named rank and then (as a separate 
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operation) located case 8, the highlighted cell would be the rank for case 8, 
which is Assistant Professor. 

 
Finding Values 

Finding values is the most useful of all the search tools, but in one important way it 
also is the most limited. It’s the most useful because any data file has more values than 
it does variables or cases. It’s the most limited because it can only search for a value 
within one variable. 

For example, let’s say we want to find the case with an age value of 36. 
1. Click the column labeled age. You may highlight any cell in the variable (or 

column) in which you want to search for the value, such as age. 
2. Click Edit →→→→ Find. When you do this, you will see the Find Data in Variable 

Age dialog box, as you see in Figure 52. 
 

 
 

Figure 52 The Find Data in Variable dialog box 
 

3. Type 36. You can search either forward or backward through the variable. If 
you highlighted the first cell in the column, you cannot search backwards 
since there’s no place to go. 

4. Click Find Next to search through the variable. SPSS will highlight the value 
when it is found. If SPSS cannot find the value, you will get a Not Found 
message. 

You can also use the Search for Data option to search for values entered as numbers 
but appearing as text (if they have been assigned labels). For example, if you wanted to 
find the first occurrence of Female in the variable named sex_prof, you would do as 
follows: 

1. Highlight any cell in the variable (or column) named sex_prof. 
2. Click Edit →→→→ Find. 
3. Type Female in the Search for Data dialog box. 
4. Click Find Next. SPSS will highlight the first occurrence of the value Female. 
The value Female was not originally entered in the cell. Instead, the value 2 was 

entered, and through the definition of the variable the label Female was assigned to that 
value. If you searched for the value 2 in the same column (sex_prof), SPSS would stop 
on all occurrences of what you now read as Female. That’s because SPSS is looking for 
data, and not necessarily for numbers or text, and Female and 2 are both data. And, if 
you entered the value female, SPSS would find Female as well, since it looks for 
whatever it can find that corresponds to what you enter in the Find Data dialog box. 
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If you want the search to be case sensitive (where upper and lower case letters are 
distinguished from one another such as Doctor and doctor), then be sure the Ignore case 
of text in strings box is checked. 
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Lesson 12 
Recoding Data and Computing Variables 

 
After This Lesson, You Will Know 

• How to recode data and create new variables 
• How to compute new values 
• How to recode into Same Variables dialog box 
• How to recode into Same Variables: Old and New Values dialog box 

 
Key Words 

• Compute 
• Compute Variable dialog box 
• Formula 
• Function 
• Recode 
 
There are often situations where you need to take existing data and convert them 

into a different variable, or to take existing variables and combine them to form an 
additional variable. For example, you may want to compute the mean or standard 
deviation for a set of variables and enter those values as a separate variable in the data 
file. Or you may want to recode data so that, for example, all values of 10 or greater 
equal 1, and all values less than 10 equal 0. Your needs for transforming or recoding 
data will depend on the nature of your data and the purpose of your analysis. In either 
case, SPSS provides some easy-to-use and powerful tools to accomplish both tasks, 
which we will show you in this lesson. 
 
Recoding Data 

You can recode data in one of two ways. First, you can recode a variable to create a 
new variable. Or you can recode a variable and modify the variable that has already 
been entered. In this lesson you will use the data saved in the file named Crab Scale 
Results on the student disk. 

As you may remember, the Crab Scale includes the following 6 items: 
1. I generally feel crabby if someone tries to help me. 
2. I generally feel happy when I watch the news. 
3. I generally feel crabby when I watch mothers and fathers talk baby talk to 

their babies. 
4. I generally feel happy when I am able to make sarcastic comments. 
5. I generally feel crabby when I am on a family vacation. 
6. I generally feel happy when I am beating someone at a game. 
Each item is ranked on the following 5-point scale. 
1. Totally agree 
2. Agree 
3. In a quandary 
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4. Disagree 
5. Vicious lies 
Since some of the crabbiness items (2, 4, and 6) are reversed, these items need to be 

recoded. For example, if someone totally agrees (a value of 1) with item 2, it means they 
are happy when they watch the news. Since we are measuring crabbiness and since the 
lower the score the more crabby someone is, the accurate scoring of this item should be 
reversed, as shown in Table 6. 
 

Table 6 
Reversed Crab Scale Scores 

 
Original response Recorded response 
1 5 
2 4 
3 3 
4 2 
5 1 
 

Here’s how to do just that. 
1. Be sure the file named Crab Scale Results is active. 
3. Click Transform →→→→ Recode →→→→ Into Same Variables, since we want the 

transformed variable to replace the values in the current variable that is being 
transformed. You should see the Recode into Same Variables dialog box, as 
shown in Figure 53. 

 

 
 

Figure 53 The Recode into Same Variables dialog box 
 

3. Double-click crab2 to move the variable into the Numeric Variables box. 
4. Click the Old and New Values … button, and you will see the Recode into 

Same Variables: Old and New Values dialog box, as shown in Figure 54. 
 

 
 

Figure 54 Recode into Same Variables: Old and New Values dialog box 
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5. Type 5 in the Value area under Old Values. 
6. Type 1 in the Value area under New Values. 
8. Click Add. The variable is added to the Old -- New box, as you see in Figure 

55. When SPSS encounters a 5 for variable 2, it will recode it as a 1. 
 

 
 

Figure 55 The Old →→→→ New Values 
 

8. Click Continue, and you will be returned to the Recode into Same Variables: 
Old and New Values dialog box. 

9. Click OK, and the actual values entered in the cells will change according to 
the way in which they were recorded. For example, if someone responded 
with a 5 to item 2 on the Crab Scale (as was the case for Professor 3), the 
recorded value would be 1. 

To recode more than one variable at a time (such as items 2, 4, and 6), just add all of 
them to the Numeric Variables box in the Recode into Same Variables dialog box. 
Computing Values 

Computing a value means taking existing data and using them to create a new 
variable in the form of a numeric expression. 

To show you how to do that, we will compute a total score for any one individual on 
the crabbiness scale based on a custom formula. To do this, we will simply add together 
the scores for variables crab1 through crab5. Keep in mind that SPSS comes with 70 
predesigned functions (a predesigned formula) that will automatically perform a 
specific computation. 

For example, we could tell SPSS to compute a new variable that is the addition of 
items crab1, crab2, crab3, crab4, and crab5. Or, we could use the SUM function that 
SPSS provides to accomplish the same end. We’ll show you how to do both. 
 
Creating a Formula 

Let’s create a formula that will add together the values of all five crabbiness items. 
1. Click Transform →→→→ Compute. When you do this, you will see the Compute 

Variable dialog box, as shown in Figure 56. 
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Figure 56 The Compute Variable dialog box 
 

2. Click the Target Variable text box and enter the name of the new variable to 
be created. We named it tot_crab, which is the sum of items 1 through 6 on 
the Crab Scale. 

3. Click the Numeric Expression text box. 
4. Click crab1, the first variable you want to include in the formula. 
5. Click the í to add it to the Numeric Expression text box. 
6. Type +. 
7. Continue adding variables and using the + key to add them together. The 

completed formula looks like this. 
crab1+crab2+crab3+crab4+crab5+crab6 

9. Click OK. As you can see in Figure 57, the variable named tot_crab was 
added to the existing data file. 

 

 
 

Figure 57 Adding a new variable to a data set 
 

For example, the tot_crab score for case 1 is 16, the simple addition of all the crab 
items (appropriately recoded, we might add!). If you wanted the average, you could 
just edit the formula in the Numeric Expression text box to read as 

(crab1+crab2+crab3+crab4+crab5+crab6)/6 
In fact, you can perform any type of mathematical computation you see fit. 

 
Using a Function 

Functions are predesigned formulas. So instead of 
crab1+crab2+crab3+crab4+crab5+crab6 

you can enter 
SUM(crab1,crab2,crab3,crab4,crab5,crab6) 

which will accomplish the same thing. 
There are more than 70 different functions including arithmetic functions, 

statistical functions, distribution functions, logical functions, date and time functions, 
cross-case functions, and string functions. It’s beyond the scope of Using SPSS… to go 
into each one and provide examples, but regardless of how complex or simple functions 
are, they are all used the same way.  

We’ll show you how to use one of the most simple and common functions, SUM, 
which adds a group of values together. 

1. Click Transform →→→→ Compute. If the dialog box is not clear, click Reset. 
2. Type tot_crab in the Target Variable text box. 
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3. In the list of functions, scroll down (if necessary) and find the function you 
want to use.  

5. Double-click on that function to place it in the Numerical Expression box. 
6. Now, add variables by double clicking them or by typing their names. The 

finished dialog box appears in Figure 58. Notice there are no “+” signs, but 
commas that separate the variables in the formula expression. 

 

 
 

Figure 58 Entering and using an SPSS function 
 

7. Click OK and the new variable is created. 
An alternative to typing in each variable in the list is to use the “to” operator. 

Instead of crab1,crab2, … through crab6, you could type crab1 to crab6 so you have 
SUM(crab1 to crab6) 

as the operators in the Numeric Expression box.  
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Lesson 13 
Sorting, Transposing, and Ranking Data 

 
After This Lesson, You Will Know 

• The differences among sorting, transposing, and ranking data 
• How to sort cases on one or more than one variable 
• How to transpose a data file 
• How to rank data 

 
Key Words 

• Data 
• Rank 
• Sort Cases 
• Transpose 
 
As you have seen in the last few lessons, working with data includes importing, 

transforming, and recoding data. Working with data also involves sorting, transposing, 
and ranking data, techniques every SPSS user needs to know to create a data file that 
exactly fits data analysis needs. We’ll look at each of these techniques in this lesson. 
Sorting Data 

The first of the three data tools is sorting. Sorting data involves reordering of data 
given the value of one or more variables. Sorting is an invaluable tool when it comes to 
organizing information. 

For example, if you wanted the data for the Crab Scale Results organized by the 
variable named rank, you would sort on that variable. If you wanted to sort on more 
than one variable, you can do that easily as well, such as a sex within rank sort. 
 
Sorting Data on One Variable 

Sorting data is as simple as identifying the variable on which you want to sort and 
directing SPSS to sort. 

1. If it is not already opened, open the file named Crab Scale Results. 
2. Click Data →→→→ Sort Cases. When you do this, you will see the Sort Cases 

dialog box, shown in Figure 59. 
 

 
 

Figure 59 The Sort Cases dialog box 
 

3. Double click Rank to move rank from the variable list to the Sort by: text box. 
The Ascending that appears next to rank in the sort box means that the 
variable will be sorted in ascending order and ascending is the default 
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condition. If you want, select descending order by clicking in the Descending 
button. 

5. Click OK. 
In Figure 60, you can see the data sorted by rank. After the sort, assistant, associate, 

and full professors are grouped together. As you can see, when alphanumeric 
information is sorted in ascending order, the sort is from A to Z. 

 

 
 

Figure 60 A completed ascending sort on one variable (rank) 
 

Tip: When you sort, the results are sorted according to the values in the cells (such 1 for male 
and 2 for female) and not the labels. If it were sorted according to the labels, then the sort 
would be with females first since ascending order for text is A through Z. 
 
Sorting Data on More Than One Variable 

Sorting data on more than one variable follows exactly the same procedure as the 
one just outlined, except that you need to select more than one variable to sort on. SPSS 
will sort in the order they appear in the Sort by list in the Sort Cases dialog box. For 
example, if you want to sort on gender within rank, then rank should be the first 
selection in the Sort Cases dialog box and gender (sex_prof) would be the second, as 
you see in Figure 61. 

 

 
 

Figure 61 Sorting on more than one variable 
 

1. Click Data →→→→ Sort Cases. 
2. Click Rank to move rank from the variable list to the Sort by: text box. 
3. Select whether you want to sort in ascending or descending order. 
4. Double click Sex of Teacher to move sex_prof from the variable list to the 

Sort by text box. 
5. Select whether you want to sort in ascending or descending order. 
6. Click OK. 
The cases have been sorted on the variable named rank, such that assistant, 

associate, and full professors are grouped together, and within rank they are sorted on 
sex_prof.  
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Transposing Cases and Variables 

As you already know, an SPSS data file is constructed with cases represented by 
rows and variables represented by columns. This is the way that most data are entered 
in any type of data collection form, including spreadsheets and other data collection 
applications. 

There may be occasions, however, where you want cases listed as columns and 
variables listed as rows. In other words, you want variables and cases transposed. This 
is most often the case when you are importing data (see lesson 10) from a spreadsheet 
where the data were not entered as cases (rows) and variables (columns). Now that 
you’ve imported the data, you want to switch them to fit the conventional SPSS format. 
Here’s how to do it. 

1. Click Data →→→→ Transpose. 
2. In the Transpose dialog box, click the variable name and then the í button to 

insert the variable in the Variables text box. Note that you cannot double-click 
to move the variable name as you can in other dialog boxes. 

3. Repeat steps 2 and 3 until all the variables that you want to become cases 
have been entered. 

4. Click OK. All the variables that were not transposed will be lost, so if you 
transpose either all the variables in the data file or just some, the ones you 
don’t will not appear after the operation is performed. 

 
Ranking Data 

The final data manipulation technique we will deal with is ranking data. Let’s say 
that we used the Compute feature (on the Transform menu) to create a sum of all Crab 
scores as we did earlier. 
 
Tip: When you want to use a procedure using the same dialog box, use the Recall dialog box 
button on the toolbar and select the dialog box you want to use. 
 

Now let’s say that we are not interested in the absolute value of the Crab score, but 
rather in the relative rank of professors according to their Crab score. Here’s how to do 
it. 

1. If you have not done so already, create a new variable (using the Compute 
command on the Data menu) named tot_crab, a total of all six crab item 
scores. 

3. Click Transform →→→→ Rank Cases. You’ll see the Rank Cases dialog box, as 
shown in Figure 62. 
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Figure 62 The Rank Cases dialog box 
 

4. Click on tot_crab and click on the í button to move the variable into the 
Variable(s): text box. 

5. Click on the Largest value button in the Assign Rank 1 to area. 
6. Click OK, and a new variable, named rtot_cra, will be created, as you see in 

Figure 63, reflecting the ranking of all cases (from 1 through 10) on the 
variable tot_crab. Cases 4 and 8 have the same tot_crab score (13), and, 
therefore, the same rank (5.5). Cases 9 and 10 also have the same (tied) rank. 

 

 
 

Figure 63 The completed ranking of data 
 

If you select more than one variable on which cases will be ranked, then a separate 
and new variable will be created for each one of those rankings, and the relative 
rankings will be listed as well.  
 
Tip: If you want to clear entries in any Variables dialog box, click on the Reset button. 
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Lesson 14 
Splitting and Merging Files 

 
After This Lesson, You Will Know 

• How to split a file 
• How to merge more than one file and more than one case 

 
Key Words 

• Add Cases from … dialog box 
• Add Cases: Read File dialog box 
• Add Variables from … dialog box 
• Add Variables: Read File dialog box 
• Merge 
• Split 
• Split File dialog box 
 
The last skills you need to master before you move on to creating and working 

with SPSS charts are how to split and merge files. When you split a file, you are 
dividing it into two new and separate files for separate analysis. When you merge files, 
you are combining two files keyed on the same variable or variables, or the same cases 
using different variables. In this lesson, we’ll look at how to do each of these. 
 
Splitting Files 

Throughout this first part of Using SPSS, you have used the Crab Scale Results and 
Teacher Scale Results to perform simple and complex procedures. We’ll use the file 
named Teacher Scale Results to demonstrate how to split a file. 

In general, you split a file when you want to create two separate files, both having at 
least one variable in common. Creating two separate files might be a choice if you want 
to produce individual listings of data or prepare data in a way that a particular section, 
split or organized using a particular variable, can be cut or copied. 

For example, in this lesson we will split the Teacher Scale Results file using the 
variable named sex_stud into two separate files. One file will be named Sex Males, and 
the other will be Sex Females. Then we can do analysis of variance or regression on the 
separate files.  
 
Tip: You can tell that a file has been split when the words Split File On are showing in the 
right hand side of the Status Bar. 
 

Splitting a file is not a particularly difficult process. In fact, it’s only a matter of 
selecting the variable on which you want to split. 

For example, for the Teacher Scale Results we’ll split on sex_stud by following these 
steps: 

1. Open the file names Teacher Scale results on the data disk. 
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2. Click Data →→→→ Split File. When you do this, you will see the Split File dialog 
box, as shown in Figure 64. 

 

 
 

Figure 64 Split File dialog box 
 

3. Click Organize output by groups since you are presumably splitting the files 
to create data for two separate analyses. 

3. Double click sex_stud. 
4. Click OK. The file will then be organized such that all male students are 

grouped together as are all female students. 
Once the split is completed, SPSS will not create two physically separate files. 

Rather, for the rest of the SPSS session, SPSS will perform every procedure as if the file 
was physically split into two separate files. A simple descriptive analysis results in 
descriptive statistics for both males and females. 

For example, if you calculate simple descriptive statistics on the variable named 
Teacher1, then you will get separate output for both males and females without having 
to identify an independent variable named sex_stud. The results of such an analysis are 
shown in the Viewer in Figure 65. Notice that the analysis was automatically done for 
both males and females. 

 

 
 

Figure 65 A simple analysis on a split file 
 

Any analysis is performed on each split of the file. For example, if you split on 
sex_stud (2 levels) and id_prof (10 levels), you would have 20 different descriptive 
analyses. 
 
Merging Files 

Merging files is just as useful as splitting files. Files can be merged, or combined, in 
two different ways. 
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First, you can combine two files that contain the same variable or variables but 
different cases. This would be the setting if more than one researcher were collecting 
data on the same variables but for different cases (or subjects), and you need to combine 
the two data files. For example, the Teacher Scale Results survey could have been 
administered to more than one group of students, and we eventually might want to 
combine the results of each administration. 

Second, you can combine two files that contain different variables but the same 
cases. For example, you might be having one person collect data using a certain sample 
and then another person collecting a different set of data on the same sample. Then you 
want these two combined. Let’s look at these possibilities. 
 
Merging Same Variables and Different Cases 

In this example, we are going to combine, merge, or add (your choice of words) a 
new set of five cases of Teacher Scale data to the existing file named Teacher Scale 
Results. You can see the new data in Figure 66 (on page 73). These data are saved as 
Teacher Scale Results—Additional Data on your data disk. 

 

 
 

Figure 66 Teacher Scale Results—Additional Data 
 

In this example one researcher collected data on 50 students, and another researcher 
collected data on five students. The Teacher Scale Results should be open. 

1. Click Data →→→→ Merge Files, then click Add Cases. When you do this, you will 
see the Add Cases: Read File dialog box, as shown in Figure 67. This looks 
like an Open or a Save dialog box, and in a sense you are opening a new file 
and merging it with another. 

 

 
 

Figure 67 The Add Cases: read File dialog box 
 

2. Locate and double-click on the name of the file to which you want to add 
cases. In this example, the file name is Teacher Scale Results—Additional 
Data. You are adding the additional data of five cases to the file that contains 
50 cases. You will see the Add Cases from … dialog box, as shown in Figure 
68. 
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Figure 68 The Add Cases…dialog box 
 

3. Click OK, and the file named Teacher Scale Results—Additional Data is added 
to the file named Teacher Scale Results, and the total file now has 55 cases (50 
cases from Teacher Scale Results—Additional Data and 5 from Teacher Scale 
Results—Additional Data). 

 
Merging Different Variables and Same Cases 

Now we have the example where you have two files that contain a different set of 
variables for the same cases. For example, we want to combine the Teacher Scale 
Results—Additional Data and Crab Scale Results files where the common variable is 
id_prof. 

What SPSS will do in this case is combine cases in the Teacher Scale Results file with 
cases in the Crab Scale Results file, using the variable named id_prof as a common link.  

1. Be sure that the file names Teacher Scale Results—Additional Data is open. 
2. Click Data →→→→ Merge, then click Add Variables. You will see the Add Variables: 

Read File dialog box. 
2. Select the file to which you want to add this set of cases. In this example, the 

file name is Crab Scale Results. 
3. Click Open and you will see the Add Variables from … dialog box, as shown 

in Figure 69. As you can see, SPSS has already identified that id_prof is 
common to the two files and has listed it in the Excluded Variables area. 

 

 
 

Figure 69 The Add Variables from dialog box 
 

4. Click OK. 
The result of this merging, shown in Figure 70, is a file larger than either of the 

two files that share the variable named id_prof. If you recall the file named Teacher 
Scale Results, you will see it does not contain any demographic information, such as 
gender or age, but the merged file including Teacher Scale information does, since it 
was merged with the Crab Scale data. 
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Figure 70 Merging two files 
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 Lesson 15 
Creating an SPSS Chart 

 
After This Lesson, You Will Know 

• How to create a simple line chart 
• About some of the different charts that you can create with SPSS 

 
Key Words 

• Area chart 
• Bar chart 
• Define Simple Line: Values of Individual Cases Dialog box 
• Line Charts dialog box 
• Pie chart 
• .spo 
 
SPSS offers you just the features to create charts that bring the results of your 

analyses to life. In this lesson, we will go through the steps to create several different 
types of charts and provide examples of different charts. In Lesson 16, we’ll show you 
how to modify a chart by adding a chart title, adding labels to axes, modifying scales, 
and working with patterns, fonts, and more. One note of caution: Throughout this unit 
of Using SPSS…, we’ll use the words graph and chart interchangeably. 
 
Creating a Simple Chart 

The one thing that all charts have in common is that they are based on data. 
Although you may import data to create a chart, in this example we’ll use the data you 
see here to create a line chart of test scores by grade. These data are available on the 
student disk in the file named Lesson 15 Data File 1. 

 Grade Score 
 1 45 
 2 56 
 3 49 
 4 57 
 5 67 
 6 72 

 
Creating a Line Chart 

The steps for creating any chart are basically the same. You first enter the data you 
want to use in the chart, select the type of chart you want from the Graph menu, define 
how the chart should appear, and then click OK. Here are the steps we followed to 
create the chart you see in Figure 71. 
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Figure 71 A simple line chart 

 
1. Enter the data you want to use to create the chart. 
2. Click Graphs →→→→ Line. When you do this, you will see the Line Charts dialog 

box, as shown in Figure 72. 
 

 
 

Figure 72  The Line Charts dialog box 
 

3. Click Simple and you will see the Define Simple Line dialog box. 
4. Click grade, click í to move the variable to the Category Axis: area. 
5. Click the Other Summary Function button. 
6. Click score, and then click í to move the variable to the Variable: area. 
7. Click OK, and you see the chart in the Output Navigator, as shown in Figure 

73. 

 
Figure 73 The default chart  
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Saving a Chart 

A chart is only one possible component of the Output Navigator window. The chart 
is not a separate entity that stands by itself, but part of all the output generated and 
displayed in the Viewer. To save a chart, you have to save the entire contents of the 
Output Navigator. To do so, follow these steps: 

1. In the Output Navigator window, click File →→→→ Save. 
2. Provide a name for the Output Navigator window. 
4. Click OK. The Output Navigator is saved under the name that you provide 

with an .spo extension (attached to all Viewer files). If you want to open this 
file later, you have to select this extension from the Files of type drop-down 
menu. 

 

 
 

Figure 74 Output is saved with the .spo extension as you can see in this dialog box. 
 
Printing a Chart 

There are several ways to print a chart. The first way is to print from the Output 
Navigator by selecting the chart and then selecting Print. 

1. Be sure that the chart you want to print is in the active Viewer window. 
2. Click on the chart so that it is selected. 
3. Click on the Print icon on the Toolbar or click File →→→→ Print and then OK. The 

chart will be printed. 
 
Tip: You can print only one or more elements in the Viewer by first selecting the element by 
clicking on it once and then select File →→→→ Print, click Selection and then click OK. To select 
more than none, hold down the Ctrl key as you click. 
 
Different SPSS Charts 

SPSS offers 17 different types of chart (all of which you can see samples of at Graphs 
→→→→ Gallery). While some types of chart may be used in lieu of others, each has its own 
purpose. The purpose depends on the type of data being charted as well as the research 
question being asked. It’s beyond the scope of this book (but just click on any icon in the 
Graphs →→→→ Gallery help area) to detail each chart and all the possible combinations, but 
you should see how some of the simple charts appear. 

Following are examples of some of these simple charts. Keep in mind that there is an 
almost infinite number of variations of the charts you can create using SPSS. You’ll 
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learn about modifying charts in Lesson 16. All sample charts that follow appear as they 
are first created, with no modification. 
 
The Bar Chart 

A bar chart represents values as separate bars with each bar corresponding to the 
value in the Data Editor. Bar charts are often used because they are easy to understand 
and require little attention to detail. In Figure 75, you can see an example of a bar chart 
of the number of males and females. 
 

 
Figure 75 A simple bar chart 

 
Tip: Charts can be easily copied (use the Edit menu) and pasted into other Windows 
applications. 
 
The Area Chart 

An area chart represents the proportions of the whole that each data point 
contributes. In Figure 76, you can see an example of average product preference as a 
function of earning power (high, moderate, and low). 

 

 
Figure 76 A simple area chart 

 
The Pie Chart 

The pie chart is a circle divided into wedges, with each wedge representing a 
proportion of the whole. Pie charts provide a clear picture of the relative contribution 
that a data point makes to the overall body of information. In Figure 77, you can see a 
simple pie chart for expenses (rent, insurance, and miscellaneous). 
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Figure 77 A simple pie chart 

 
Keep in mind that when you first create a chart, all the SPSS defaults are used. You 

can easily change type size and font and many other characteristics. You will learn how 
to do that in the next lesson.  
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Lesson 16 
Enhancing SPSS Charts 

 
After This Lesson, You Will Know 

• How to modify chart elements, including titles, axes, colors, and patterns 
 
Key Words 

• Category Axis 
• Category Axis dialog box 
• Colors dialog box 
• Patterns dialog box 
• Pattern dialog box 
• Scale Axis 
• Scale Axis dialog box 
• SPSS Chart Editor 
• Text Styles dialog box 
• Titles dialog box 
 
A picture might be worth a thousand words, but if your pictures or charts don’t 

say what you want, what good are they? Once you create a chart, as we showed you in 
the last lesson, you can finish the job by editing the chart to reflect exactly your 
meaning. Color, shapes, scales, fonts, text, and more can be altered, and that is what 
you’ll do in this lesson. We’ll be working with the line chart that was first shown to you 
in Figure 71. Only in this case we’ve made all the modifications. 
 
Modifying a Chart 

The first step with the modification of any chart is to double-click on the chart in the 
right pane of the Output Navigator to access the SPSS Chart Editor and then click the 
maximize button on the Application title bar. As you can see in Figure 78, there is a 
Chart toolbar containing a set of buttons across the top of the chart. In Figure 79, you 
can see each button better and what each represents. 
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Figure 78 The Chart Editor 
 

 
 

 
Figure 79 The Chart Editor tools  

 
One cautionary note before we begin. The most basic reason for modifying a chart 

should be to increase the chart’s ability to communicate your message. If you get caught 
up in Chart Junk (a close cousin to Font Junk), you’ll have a mess on your hands. 
Modify to make better, not to show your reader that you know how to use SPSS. 

One instructional note before we begin. The general strategy for changing any 
element in a chart is to select the chart element and then make the change. You select a 
chart element much as you select any Windows element, by clicking on it. If you single-
click, you then must select the menu command for the item you want to change. If you 
double-click in some cases, you will go immediately to the dialog box in which you can 
make the change. 
Working with Titles and Subtitles 

Our first task is to enter the title and a subtitle for the chart you see in Figure 71. 
1. With the Chart editor open, Click Chart →→→→ Title. When you do this, you will 

see the Titles dialog box, as shown in Figure 80. 
 

 
 

Figure 80 The Title dialog box 
 
2. Type Score by Grade in the Title 1: section. 
3. Press the Tab key. 
4. Type 10/8/2001 in the Title 2: section. 
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5. Click Center from the drop-down menus for justification of the titles. 
6. Click OK. 
The titles (and subtitle if you entered one) appear as elements on the chart. If you 

want to edit a title or a subtitle, just be sure that the chart is active and select Title from 
the Chart menu. 
 
Working with Fonts 

Now it’s time to work with the font used to represent any text in the chart. You can 
do this one of two ways, with each way yielding the same dialog box used to change 
fonts. 

1. Select the area of the chart containing the font you want to change. When you 
select text, it appears with a solid line around it. In this example, we selected 
the title of the chart, Score by Grade. Once selected, it appears with a box 
around it. 

2. To select a new font and size, you can either select Text from the Format 
menu or click on the Text button on the toolbar. When you do either of these, 
you will see the Text Styles dialog box, shown in Figure 81. 

 
 

 
 

Figure 81 The Text Styles dialog box 
 

3. Select the font and size you want to use. 
4. Click Apply, and the font will change in the chart. The Text Styles dialog box 

will remain on the screen until you close it. That way you can make several 
text style changes without having to reselect the Text Styles dialog box. 

The font size was set at 14 point for the first title and 12 point for the second title. 
The font used was Book Antigua for both title elements. You cannot highlight more 
than one text area at a time, so you have to highlight each one and then select the font 
you want to use. 

 
Tip: A definitely forward thinking feature of SPSS is that dialog boxes often can stay open as 
you apply changes so that you can immediately see the effect of the change. You can also 
make several changes without have to open and close the dialog box each time. 
 
Working with Frames 

SPSS, by default, places a frame around the top and right side of the chart, an 
inside frame. And if you want, it can also place a frame around the entire chart, called 
an outside frame. To include or exclude an inner and outer frame, select the option 
(Inner Frame or Outer Frame or both) from the Chart menu. In our graph, the graph’s 
inner frame was removed, making for a less cluttered appearance. 
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Working with Axes 
The X and Y axes provide the calibration for the independent (usually the X axis) 

variable and the dependent (usually the Y axis) variable. SPSS names the Y axis the 
Scale Axis and the X axis the Category Axis. Each of these axes can be modified in a 
variety of ways. To modify either axis, double-click on the title of the axis. 
 
How to Modify the Scale (Y) Axis 

For example, to modify the Y axis, follow these steps: 
1. Double-click on the label (Mean SCORE) of the axis, and not the axis itself. 

When you do this, you will see the Scale Axis dialog box, as shown in Figure 
82. 

 

 
 

Figure 82 The Scale Axis dialog box 
 

2. Select the options you want from the Scale Axis dialog box. We changed the 
label Value Score to Score and centered the axis title. We could have done 
several other things, such as changing the range of the scale (which is 40 to 80 
based on data values of 45 and 72) and working with major divisions and 
minor divisions. 

 
Working with the Category (X) Axis 

Working with the X axis is exactly the same as working with the Y axis. Here’s how 
the X axis was modified. 

1. Double-click on the label of the X axis. The Category Axis dialog box opens as 
shown in Figure 83. 

 

 
 

Figure 83 The Category axis dialog box 
 

2. Select the options you want from the Category Axis dialog box. We changed 
the Category title from GRADE to Grade and centered it. Our finished and 
modified line chart is shown in Figure 84. We got back to the output window 
by closing the Chart Editor when we were done modifying the chart. 
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Figure 84 A modified line chart. 
 

Working with Patterns and Colors 
Time to have some fun (and be practical besides). When SPSS creates a chart, and 

if you have a color monitor, it assigns different colors or symbols to different elements 
in a chart. We’ll use two tools, one to work with patterns and one to work with colors. 
We’ll use a simple bar chart, as shown in Figure 85, as an example. 

 

 
 

Figure 85 A simple bar chart 
 
Changing Patterns 
To change the patterns of any element in a chart, follow these steps: 

1. Double-click to open the Chart Editor. 
2. Click on the chart element you want to select. When you select a chart 

element, handles are placed on the edges of all the elements that are identical. 
In this case, we will click on one of the bars and all the bars are selected. 
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3. Click on the Fill Pattern button or click Format →→→→ Fill Pattern and you will 
see the Pattern dialog box shown in Figure 86. 

 

 
 

Figure 86 The Fill Pattern dialog box 
 

4. Click on the pattern you want to use. 
5. Click Apply, and the pattern used in the bars will change. In the bar chart you 

see in Figure 87, the hatched pattern was used for the Sex of Student variable. 
 

 
 

Figure 87 Changing the fill pattern for a bar chart 
 

Now that the patterns are straight, we have one more step. We will eliminate the 
color from the bars since printing on color (your printer will see the colors as being 
black or a shade of gray) uses lots of toner. 
 
Changing Colors 
To change the color of any element in a chart, follow these steps: 

1. Click on the chart element you want to select if it is not already selected. 
2. Click on the Color button, or click Format →→→→ Color. When you do this, you 

will see the Colors dialog box shown in Figure 88. 
 

Tip: You can customize chart colors by clicking Edit in the Colors dialog box. 
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Figure 88 The Colors dialog box 
 

3. Select the color you want to use to fill the bar, which in our example is white. 
4. Click Apply. 
5. Select the color you want to use (if any) for the border of the bar, which in this 

example is black. 
6. Click Apply and you have your newly patterned and colored bar chart as 

shown in Figure 89. 
 
 

 
 

Figure 89 Changing the pattern and color in a simple bar chart. 
 

Setting Chart Preferences 
Now that you know something about creating and modifying charts, you should 

know there are certain default settings that you can set before you create a chart under 
Options on the Edit menu. They allow you to choose a particular format for viewing 
your charts. These settings, shown in Figure 90, allow you to set the following visual 
elements: 
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Figure 90 The Options dialog box 
 
Tip: You can set the Chart (and other) defaults you want to use in the Options dialog box at 
Edit 

• the font used in the chart 
• the nature of how items are filled with patterns or colors 
• the height to width ratio of the chart 
• the presence of a frame (inside and/or outside) 
• the presence of grid lines 

For example, if you want the initial chart to use Times Roman as a font, specify it in 
the SPSS Options dialog box you access through the Edit menu in the Chart Editor. 
Getting Fancy 

Before we finish with this bar chart and with your introduction to SPSS charts, let’s 
add just a few more things to jazz up the bar chart. 

First, let’s click on the Bar Label Styles button and place the corresponding Y axis 
value at the top of each bar. This simple change increases the informative nature of the 
chart. Let’s make some changes in axis labels and add a footnote and you see the 
finished chart in Figure 91. 

 

 
 

Figure 91 A more informative bar chart 
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Lesson 17 
Using the Viewer 

 
After This Lesson, You Will Know 

• The use of the two panes in the Viewer 
• How to save output 
• How to show and hide results in the Viewer window 
• How to print output 
• How to delete output 
• How to move output 

 
Key Words 

• Contents pane 
• Outline pane 

 
The Viewer 

When you complete any type of procedure in SPSS, be it the creation of a simple 
chart or the results of a complex analysis, the output appears in the Viewer. The Viewer 
is a separate SPSS screen that lists all operations performed on a set of data in the order 
in which they were completed. 

For example, in Figure 92, you can see the Viewer showing a bar chart (Graph). 
 

 
 

Figure 92 SPSS results in the Viewer window 
 
Until you save the contents of the Viewer using a new name, the Viewer window 

will keep the name that SPSS assigned when it was first created. Unless named by you, 
the names automatically assigned are Output1, Output2, etc. 

The Viewer consists of two panes. The Outline pane on the left side of the Viewer 
and the Results pane on the right side of the Viewer. 
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The Outline pane lists in outline form all the analyses that have been completed 
during the current session. The Contents pane contains the results of the analyses.  
 
Saving Viewer Output 

Once output is generated, you will probably want to save it for later use or even to 
add it to another work session. To save output from the Viewer, follow these steps: 

1. Click File →→→→ Save. 
2. Provide a name for the output. 
3. Click OK. The output will be saved using the file name that you provided, 

along with the .spo extension. When you want to open the Viewer you saved, 
you will have to specify the .spo extension in the File Type drop-down menu 
in the SPSS Open dialog box. 

 
To Selectively Show and Hide Results 

You can choose to show or hide any results that appear in the Viewer window. You 
may generate results that you want to hide while you print out others, a convenient 
way to be selective as you focus your discussion of the results. 

To hide a table or chart without deleting it, follow these steps: 
1. Click on the item in the Outline pane. 
2. Click View →→→→ Hide. 

 
Tip: The red arrow in the Outline or Results pane indicates which element in the Viewer is 
active. 

 
To show a table or chart once it has been hidden, follow these steps: 
1. Click on the item icon in the Outline pane. If you click on the item name, then 

you will simply highlight the name and the Show option on the View menu 
will not be active. 

2. Click View →→→→ Show. The item reappears in the Contents pane. 
You’ll want to hide and show output as you decide what you want to appear in a 

hard copy of the Viewer. 
Printing the Contents of the Viewer Window 

To print the entire contents of the Viewer, follow these steps: 
1. Click File →→→→ Print. 
2. Click OK. All the tables and charts in the Viewer will be printed. 

 
Printing a Selection from the Viewer Window 

To print a specific selection from the Viewer window such as a table or a chart, 
follow these steps: 

1. Click on the table, chart, or both that you want to print in the Viewer 
window. You can select more than one element by holding down the Shift or 
Ctrl key when you click each element. 

2. Click File →→→→ Print. 
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3. Click Selection →→→→ OK. The element or elements you selected will be printed. 
Any element surrounded by a black line is selected and will print. You can select as 

many elements as appear in the Contents pane to print at once. 
 
Deleting Output 
To delete output from the Viewer, follow these steps: 

1. Click on the output you want deleted, either in the Outline or Contents pane 
of the Viewer window. 

2. Click Edit →→→→ Delete, or press the Del key. 
 
Tip: If you select an item in the Results pane and press the Del key, the item will be deleted 
and can be recovered using the Ctrl+Z key combination. 
 
Moving Ouput 

Although the results in the Viewer window appears in the order it was created, you 
can change the order in which it appears. To change the order, do the following. 

In the Outline pane of the Viewer, drag the icon (not the name) representing the 
output to its new location. 

For example, in Figure 93, you can see that the element titled Descriptive Statistics is 
being moved to the place above the element titled Notes and below Title and how the 
Outline pane appears after the move in Figure 94. Remember that the order in which 
elements appear in the Outline pane directly reflects their order in the Results pane.  
 

 
 
 

 
Figures 93 and 94 Moving results in the Outline pane. 
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